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Liability and Copyright for the Hardware 
This manual and everything described in it are copyrighted. You may not copy this manual, in 
whole or part, without written consent of Panasonic Electric Works Europe AG. 

Panasonic Electric Works Europe AG pursues a policy of continuous improvement of the 
design and performance of its products, therefore, we reserve the right to change the 
manual/product without notice. In no event will Panasonic Electric Works Europe AG be liable 
for direct, special, incidental, or consequential damage resulting from any defect in the product 
or its documentation, even if advised of the possibility of such damages. 

We invite your comments on this manual. Please email us at: 
tech-doc@eu.pewg.panasonic.com. 

Please direct support matters and technical questions to your local Panasonic representative. 

 

LIMITED WARRANTY 
If physical defects caused by distribution are found, Panasonic Electric Works Europe AG will 
replace/repair the product free of charge. Exceptions include: 

• When physical defects are due to different usage/treatment of the product other than 
described in the manual. 

• When physical defects are due to defective equipment other than the distributed 
product. 

• When physical defects are due to modifications/repairs by someone other than 
Panasonic Electric Works Europe AG. 

• When physical defects are due to natural disasters. 
 

 

 

 

 

 

 

 

 

 

 

 
© MS-DOS and Windows are registered trademarks of Microsoft Corporation. 
© IBM Personal Computer AT is registered trademark of the International Business Machines Corporation. 



 



Limitation of Liability 
The hardware and software of the alarm notification system has been developed and checked 
by Panasonic Electric Works (PEW) with great care. 

In no event will PEW be liable for physical defects due to different usage/treatment of the 
product other than described in the manual, especially defects resulting from modifying the 
components or combinations with non-PEW products. 

In no event will PEW be liable for unsuitable SIM cards, failures in the mobile communication 
network or problems with the provider services. 

Please also refer to the safety and warranty notes in your PLC's manual. 

Copyright © 

 Control Configurator MS Lib 
Copyright © 2006 Panasonic Electric Works Europe AG 
Rudolf-Diesel-Ring 2, 83607 Holzkirchen, Germany 
Version: 1.1 

 

 
 



Important Symbols 
One or more of the following symbols may be used in this manual: 

 

Warning. 
The warning triangle indicates especially important 
safety instructions. If they are not adhered to, the 
results could be: 

• fatal or critical injury and/or 

• significant damage to instruments or their contents, 
e.g. data 

 

 
Contains important additional information. 

 
Contains an illustrative example of the previous text section. 

 

Indicates that a step-by-step procedure follows. 

 
Indicates where you can find additional information on the subject at hand. 

 
Indicates that you should proceed with caution. 



 

 
Summarizes key points in a concise manner. 

 
Provides helpful keyboard shortcuts. 

 
Provides brief explanation of a function, e.g. why or when you should use it. 

 next page 

Indicates that the text will be continued on the next page. 

 

The manual uses the following conventions to indicate elements from the user interface or the 
keyboard: 

 
"Data Field" Data field entries and option names are rendered in quotation marks. 
[Button] Buttons are indicated by square brackets. 
<Key> Keys are indicated by pointed brackets 
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1.1 What is Control Configurator MS Lib? 
The configuration software Control Configurator MS Lib helps you to set up a GSM alarm 
notification system (GSM = Global system for mobile communication). 

You can download the parameters you have entered during the configuration to the PLC, for 
example, phone number, phone number priorities, messages to be sent, delay times, PIN, etc. 
When you need to change the PLC configuration, you can upload the data from the PLC and 
modify them. 

PLC-based GSM alarm 
notification system

PLC 
programming 
cable

RS232 COM port

PLC tool port

Control Configurator MS
Version 1.0
AFPS34610-D-1533572

 
 

 
• The Control Configurator MS Lib can only configure the GSM alarm 

notification system contained in the FPWIN Pro library NCL-CCMS-LIB. 

• If you wish to use the Control Configurator MS Lib to download a 
configuration to the PLC or to upload the PLC configuration, the GSM alarm 
notification system needs to be stored in the PLC. For this purpose you need 
to install the library NCL-CCMS-LIB in your FPWIN Pro project, enter the 
POUs of the GSM alarm notification system in the task pool and download 
the project to the PLC. 

• For further information on how to use the library NCL-CCMS-LIB please refer 
to the library's online help. 
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1.2 Software Features 
The software offers the following features: 

Notification If Problems Occur 
• Send messages if input is switched ON or OFF 

You can configure up to 8 or 28 inputs and send up to 16 or 56 messages for these 
inputs. 

• Set time delay for inputs 
It is possible to filter input signals by defining how long an input signal has to be active 
before a message will be sent. 

• Send messages to up to 4 phone numbers 
Depending on your mobile phone service provider you can send messages also to a fax 
or email address. 

• Multiple recipients 
You can send one message to one or more phones at the same time. 

• Use acknowledgement for messages 
If a sent message is not acknowledged by a reply to the alarm notification system within 
a defined period of time, you can have the system send the message to other phones. 

• Station name included in every message 

• Watch account on prepaid cards 

Remote Control 
• Switch up to 8 or 28 outputs ON or OFF by sending one message 

• When an output has been switched, you can switch the output back with a time delay. 

• You can define the initial state of the outputs. You can make the PLC remember the 
state of outputs if a power failure occurs. 

• Check whether the PLC has acted correctly on a message by defining a confirmation 
message to be sent as a reply with the current output status. 

• Check the current status of the alarm notification system by sending a message to 
request the status from the system. The alarm notification system replies with a 
message containing the current status of the inputs and outputs and any currently active 
alarm messages to the phone which has sent the status request. 

Remote Maintenance 
• Change phone numbers by sending a message to the alarm notification system 

• Assign a different pool to a phone number by sending a message to the alarm 
notification system 

• Define confirmation messages for the PLC to send when it has acted correctly on 
received messages. 

• Send a message to switch the alarm notification system into a state that allows remote 
configuration. 
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Other Features 
• Data input is checked for validity 

• Diagnostic functions inform you about the state of the alarm notification system 

• Load a project from a file/Save a project to a file 

• Upload/Download a project from/to the programmable logic controller (PLC) 

• Print and preview a project 

• Available in several languages 
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1.3 Mobile Communication Requirements 
In order for the alarm notification system to work reliably, the following requirements must be 
met. 
 

1.3.1 Which Mobile Phone Service Providers Are Supported? 

The alarm notification system can be used in all countries with a GSM mobile communication 
network. Depending on the GSM terminal used, the remote monitoring systems works with a 
network with GSM900 MHz and/or GSM1800 MHz. 
 

1.3.2 Which SIM Cards Can Be Used? 

In order to be able to send messages with a mobile phone you need SIM card (Subscriber 
Identification Module) authorization. To obtain a SIM card, you need a contract with a mobile 
phone service provider, e.g. at  a mobile phone shop The activated SIM card is inserted in the 
GSM terminal. The SIM card provides the GSM terminal with a phone number and authorizes 
the access to the mobile communication network. 

Types of SIM Cards 
 

Card type Properties 
Prepaid card Prepaid cards offer the advantage that there is no contract and no monthly fee. With a 

prepaid card, you pay in advance for the communication service. This is different for contract 
phones, where you receive a monthly bill charging you for phone calls made and messages 
sent. 
The disadvantage of prepaid cards is that the PLC cannot send any more messages if the 
credit on the card has been used up and you have not added new credit to the SIM card. This 
is why you need to watch the account on the prepaid card. Another disadvantage is that the 
prepaid card may expire after a certain time (depends on the mobile phone service provider). 
To stop the card from expiring, you need to add new credit to the SIM card in regular intervals. 

SIM card with a 
contract 

As a rule, SIM cards with contracts are more expensive than prepaid cards due to the basic 
monthly fee. However, since you are billed afterwards for all calls made, it cannot happen that 
messages are not sent (as can happen with prepaid cards when their credit has been used 
up). 

 
 

1.3.3 Hardware Requirements 

Panasonic Products 
The GSM alarm notification system of the FPWIN Pro library NCL-CCMS-LIB can be used with 
all Panasonic PLCs with a free programmable RS232 interface. 

In addition to the PLC you usually need a 24V DC power supply, a PLC programming cable, and 
a cable for connecting the PLC's COM port with the GSM terminal. 
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For further information on how to connect the PLC port to a GSM terminal please 
refer to the online help of the library NCL-CCMS-LIB. 

Third-Party Products 
• GSM terminal: for example Siemens TC35i, TC35, MC35, or Wavecom WMOD2, 

Fastrack, or SAGEM TAINY GMOD-T1 

• Power supply cable for the GSM terminal 

• Antenna for the GSM terminal 

• SIM card 
For further information on the hardware requirements for installing the software on your PC, 
please refer to "System Requirements and Installation" (see page 9). 
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1.4 Abbreviations 
In this documentation, the following abbreviations are used: 
 

Abbreviation Meaning 
GSM Global system for mobile communication 

PIN Personal identification number 

SIM Subscriber identification module 

SMS Short message service 

PLC Programmable logic controller 
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2.1 Hardware Requirements for the PC 
Before you install Control Configurator MS, check whether the PC meets the following 
requirements: 

• 80486 processor or better 

• at least 64MB RAM 

• S-VGA graphic adapter (800 x 600 pixels) or better 

• hard disk, CD ROM drive 

• at least 20MB free disk space 

• free serial port (RS232) 

Operation System Requirements 
Win 98, ME, NT 4.0, 2000, XP 
 



Control Configurator MS Lib V1.0 

 

2.2 Software Installation 

11 

2.2 Software Installation 
For the standard installation please proceed as follows: 

 
1. Insert the installation CD for the FPWIN Pro library NCL-CCMS-LIB in the CD 

ROM drive of your computer 

2. Select "Execute" from the Windows start menu and enter D:\Control 
Configurator MS Lib 1.exe in the text box. 

In this example, D: is the letter for the CD ROM drive. 

3. Choose [OK] and follow the instructions on the screen 

Alternatively, you can execute the software directly from the installation CD. In the Windows file 
manager select the CD ROM drive and double-click the file "Control Configurator MS Lib 
1.exe". 
 



Installation 

 

Control Configurator MS Lib V1.0 

12 

2.3 Hardware Installation 
The correct installation is shown in the figure below. 

 
For correct wiring, please refer to the installation guide for the other 
components such as the GSM terminal and the antenna with magnetic base. 
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(order number
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DIN rail (optional)

PLC FP0
(order number
FP0-C10CRS, 
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FP0-C16CT, 
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Power supply cable 24V DC
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Power supply cable 24V DC
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Control Configurator MS Software
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Note: You only need a PC and the programming cable to configure the alarm
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3.1 Create Project 

Use Project → New or  to display the start page (see page 20) for creating a new project. 
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3.2 Upload Project from the PLC 

Choose PLC → Upload Project or .  First you need to connect the PLC as described in 
hardware installation (see page 12) and supply the PLC with power. The connection with the 
PLC uses the communication parameters you have defined and uploads the project from the 
PLC to Control Configurator MS. 

 
• The Control Configurator MS Lib can only configure the GSM alarm 

notification system contained in the FPWIN Pro library NCL-CCMS-LIB. 

• If you wish to use the Control Configurator MS Lib to download a 
configuration to the PLC or to upload the PLC configuration, the GSM alarm 
notification system needs to be stored in the PLC. For this purpose you need 
to install the library NCL-CCMS-LIB in your FPWIN Pro project, enter the 
POUs of the GSM alarm notification system in the task pool and download 
the project to the PLC. 

• For further information on how to use the library NCL-CCMS-LIB please refer 
to the library's online help. 

• For technical reasons, the PLC must be in RUN mode during the upload 
procedure. If the PLC is in PROG mode, it is automatically switched to RUN 
mode until the project has been uploaded; then it returns to PROG mode. 
 However, during the short time when the configuration is uploaded and the 
PLC is in RUN mode, the program will be processed. 
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3.3 Download Project to PLC 

Choose PLC → Download Project or . First you need to connect the PLC as described in 
hardware installation (see page 12) and supply the PLC with power. The connection with the 
PLC uses the communication parameters you have defined and Control Configurator MS 
downloads the project to the PLC. 

 

 
• The Control Configurator MS Lib can only configure the GSM alarm 

notification system contained in the FPWIN Pro library NCL-CCMS-LIB. 

• If you wish to use the Control Configurator MS Lib to download a 
configuration to the PLC or to upload the PLC configuration, the GSM alarm 
notification system needs to be stored in the PLC. For this purpose you need 
to install the library NCL-CCMS-LIB in your FPWIN Pro project, enter the 
POUs of the GSM alarm notification system in the task pool and download 
the project to the PLC. 

• For further information on how to use the library NCL-CCMS-LIB please refer 
to the library's online help. 

• When you download a project to the PLC, the "Waiting for acknowledgement 
message" flag will be reset. 

• For technical reasons, the PLC must be in RUN mode during the download 
procedure. If the PLC is in PROG mode, it is automatically switched to RUN 
mode. After the project has been downloaded, the PLC remains in RUN 
mode. 
Please remember that the PLC processes the program in RUN mode. 
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3.4 Working with Projects and the RS232 Port 
You find a detailed description of the project options and the communication parameters in the 
online help. The online help contains information on topics such as: 

• Create project 

• Open project 

• Save project 

• Print project 

• Check project 

• Upload project from the PLC 

• Download project to PLC 

• Communication parameters 

• Change the language setting of the user interface 
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3.5 Help 
Clicking Help in the menu bar will initiate the display of the software help functions. 
 

3.5.1 Contents 

With Help → Contents you initiate the display of the help contents described in the online help. 

 
1. Help → Contents 

2. Click topic in the navigation pane 

An explanation or a further selection will be displayed. Click the button [Locate] in 
the tool bar of the help window to synchronize the explanation window with the 
navigation pane. 

Use [Add] to enter frequently used help topics to the "Favorites" page. 
 

3.5.2 What's This? 

Select Help → What's This? and point the mouse to an input or text field in the software (the 

mouse cursor changes to ). The software displays the corresponding help topic. 
 

3.5.3 Search for Help on 

With Help → Search you can search for terms and contents in the help system. You can either 
key in or click the term in the selection list. 
 

3.5.4 About Control Configurator MS 

Use Help → About Control Configurator MS to display information about the version and the 
copyright. 
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4.1 Index Cards and Tabs 
Select an index card by clicking the tab at the top. 

Tab of the index card

 
Activate index card with the tab 

For information on the available settings on the different index cards, please refer to the online 
help and search for the index card. 
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