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Introduction

Thank you for using HG-T Configuration Tool.
This user's manual explains how to set up and operate the HG-T Configuration Tool software,
which is used in combination with the HG-T series thru-beam type digital displacement sensor
and compatible communication unit.
Before using this product, read and understand this user's manual. Use the product correctly
and in the optimum manner.
Keep this manual in a safe location for reference whenever necessary.

Types of Manuals

The following user’s manuals are available for the HG-T. Refer to the appropriate manual
according to your need.
The user’s manuals are also available for download from our website (https://
industry.panasonic.com/).

Unit name or purpose of
use Manual name Manual code

HG-T Control Unit HG-T User’s Manual WUME-HGTM

Tool software for the HG-T
series

HG-T Configuration Tool
HG-T Configuration Tool User’s Manual WUME-HGTCT

RS-485 Communication Unit
for Digital Displacement

Sensors
SC-HG1-485 User’s Manual WUME-SCHG1485

Notes

1. No part of this manual may be reproduced or reprinted in any form or by any means without prior written
permission from Panasonic.

2. The contents of this manual are subject to change without notice for future improvement.
3. This manual has undergone strict quality control; but should you discover any dubious information or

mistakes, please contact your local dealer or our call center.
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Manual Configuration

Chapter
1

Before Using This Product This chapter explains the safety, handling precautions.

Chapter
2

System Configuration This chapter explains the system configuration and recommended
environment for using HG-T Configuration Tool.

Chapter
3

System Requirements
Specification

This chapter explains the system requirements specification.

Chapter
4

Installing HG-T
Configuration Tool

This chapter explains how to install HG-T Configuration Tool.

Chapter
5

Starting and Exiting HG-T
Configuration Tool

This chapter explains how to start and exit HG-T Configuration Tool.

Chapter
6

Name and Function of Each
Window

This chapter explains the name and function of each window.

Chapter
7

Setting up the Main Unit This chapter explains how to set up the main unit using HG-T
Configuration Tool.

Chapter
8

Using Convenient Functions This chapter explains the convenient functions of HG-T
Configuration Tool.

Chapter
9

Troubleshooting This chapter explains error messages and alarm messages.
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1.1 Handling Precautions

■ In this manual, the following symbols are used to indicate safety information that
must be observed.

Indicates an action that is prohibited or a matter that requires caution.

Indicates an action that must be taken.

Indicates supplemental information.

Indicates details about the subject in question or information useful to remember.

Indicates operation procedures.

1.1 Handling Precautions
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1.2 Terminology

Term Description

Software
“HG-T Configuration Tool"

HG-T Configuration Tool is tool software dedicated to the HG-T series
controllers. This software enables the user to set up the HG-T series
controllers connected via the compatible communication unit, display
received light waveforms, and perform other operations.

USB communication unit
“SC-HG1-USB” An interface unit that enables measurement data and other data of

connected controllers to be monitored.(Note 1)RS-485 communication unit
“SC-HG1-485”

HG-T series controller - Master unit A controller that can be used on a standalone basis.

HG-T series controller - Slave unit A controller that is used by connecting to a master unit.

End plate or commercially available
fitting

A part that is used to secure both edges of a connector to prevent the
connector from coming off and causing a communication failure when
controllers are connected.

 

(Note 1) For details on each communication unit, refer to the instruction manual supplied with the product.
 

1.2 Terminology
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1.3 Software Version and Setting Functions

■ HG-T Configuration Tool Ver.1.30 (Released in November 2020)
Functions added

Added function Description

User assigned edge detection Measurement settings Operation mode setting

Tab cancel function Correction settings

Hold state output Operation setting Digital I/O

Measured value reversal selection
function

Measurement settings

 

(Note 1) For details on each function, refer to the HG-T User's Manual.
 

The above functions are available only when the HG-TC□ series controller is combined with the
HG-T□ series sensor head, both of which are manufactured in November 2020 onwards.
Those functions cannot be used with the controllers and sensor heads manufactured in October
2020 or earlier.
Other changes

Some screen layouts and screen user interface designs
Please be careful when using this Software with version earlier than Ver.1.30. It is
recommended to upgrade to Ver.1.30 or later.
This Software with Ver.1.30 or later can also be used with the controllers combined with the
sensor heads, both of which are manufactured in October 2020 or earlier.
Please download the latest version from our website (https://industry.panasonic.com/).

1.3 Software Version and Setting Functions
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2 System Configuration
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2.1 System Configuration

● Tool software HG-T Configuration Tool is used in combination with compatible
communication unit.

For USB communication unit

For details on the communication unit, refer to the instruction manual supplied with the SC-
HG1-USB.

For RS-485 communication unit

To connect the RS-485 communication unit and PC, an RS-485-to-USB converter is required.
For details, refer to the instruction manual of the RS-485-to-USB converter to be used and the
SC-HG1-485 User’s Manual.
Versions of HG-T Configuration Tool that are earlier than Ver. 1.2 do not recognize RS-485
communication units.
Download the latest version of HG-T Configuration Tool from our website (https://
industry.panasonic.com/).

2.1 System Configuration
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2.2 Tool Software “HG-T Configuration Tool”

HG-T Configuration Tool is tool software dedicated to the HG-T series controllers.
Installing this tool software on a PC enables the user to set up the connected HG-T series
controllers, display received light waveforms, and perform other operations.

2.2 Tool Software “HG-T Configuration Tool”
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2.3 HG-T Control Unit

HG-T control units are connected to the compatible communication units.
Compatible controller models are shown below.

Compatible models

HG-TC101 / Master unit of high-performance NPN
output type
HG-TC101-P / Master unit of high-performance PNP
output type

HG-TC111 / Slave unit of high-performance NPN
output type
HG-TC111-P / Slave unit of high-performance PNP
output type

HG-TC113 / Slave unit of wire-saving type

Note: For details on control units, refer to the user's manual for each control unit.

Compatible communication units

SC-HG1-USB / USB communication unit SC-HG1-485 / RS-485 communication unit

Note: For details on compatible communication units, refer to the user's manual for each
communication unit.

2.3 HG-T Control Unit
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3 System Requirements
Specification

3.1  System Requirements Specification ...................................................3-2
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3.1 System Requirements Specification

The following operating conditions are required to use the tool software. Check whether the
system to be used meets the conditions and the necessary devices are prepared.

System requirements

Item Specifications

OS(Note 1) Windows(R) 11(64bit)

Windows(R) 10(32bit/64bit)

CPU(Note 2) Intel(R) Core™ i3　2GHz or faster

Memory
2GB or more[Windows(R) 10(32bit)]

4GB or more[Windows(R) 10(64bit)]

4GB or more[Windows(R) 11(64bit)]

Available hard disk space 2GB or more

Screen language Japanese, English, and Chinese (Simplified), Korean

Communication interface USB 2.0, RS-485

Operating conditions .NET Frameworks 4.6.2 or later must be installed.
 

(Note 1) Windows is a registered trademark or trademark of Microsoft Corporation in the United States and/or
other countries.

(Note 2) Intel(R)and Core™ are registered trademarks or trademarks of Intel Corporation and its subsidiaries in
the United States and/or other countries.

 

3.1 System Requirements Specification
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4 Installing HG-T Configuration
Tool

4.1  Installation...........................................................................................4-2
4.2  Uninstallation ......................................................................................4-6
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4.1 Installation

This section explains the procedure for installation on a PC.

● Windows warning messages such as "User Account Control" and "Windows can't verify the
publisher of this driver software" may be displayed, but there is no problem and you can
proceed to the next step.

1. Open the folder containing the downloaded file and double-click [setup.exe].

2. Select the target language and click the [OK] button.

3. Click the [Next] button.

4.1 Installation
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4. The"License Agreement"window will be displayed. Carefully read the agreement, select"I
accept the terms in the license agreement", and then click [Next] button.

5. If you do not change the installation folder, click the [Next] button. If you change the
installation folder, specify a desired folder and then click the [Next] button.

6. Click the [Install] button.

4.1 Installation
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7. Click the [Finish] button.

8. The HG-T Configuration Tool icon will be displayed on the desktop.

4.1 Installation
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4.1 Installation
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4.2 Uninstallation

Uninstall the following item.
● Panasonic Industry Sensor HG-T Configuration Tool
In Windows, select Start>Control Panel>Programs and Features in this order and then
uninstall the specified items.

4.2 Uninstallation
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5 Starting and Exiting HG-T
Configuration Tool

5.1  Starting HG-T Configuration Tool.....................................................5-2
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5.2.1  Starting by loading the settings from USB communication unit ....... 5-3
5.2.2  Starting by loading the settings from RS-485 communication unit .. 5-4
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5.1 Starting HG-T Configuration Tool

This section explains the procedure for starting HG-T Configuration Tool.

Use the following procedure to start HG-T Configuration Tool.

1. Double-click the HG-T Configuration Tool icon on the desktop. Alternatively, click the
Windows [Start] button and, from all the programs, select Panasonic Industry
Sensor>HG-T Configuration Tool.

2. When HG-T Configuration Tool is started, the "Start menu" dialog box is displayed.

No. Item Description

1 "Create a new file" Allows the user to create a new HG-T configuration file.

2 "Open a file" Allows the user to open an existing HG-T configuration file.

3 "Read from sensors" Allows the user to load the settings of the HG-T main unit (sensor)
from the HG-T main unit via the communication unit.

4 “Communication unit being
connected” display area

This area displays the communication unit that is currently
connected. If "Read from sensors" is selected, this area will be
enabled.

5.1 Starting HG-T Configuration Tool
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5.2 Starting by Loading the Settings from Communication Unit

Use the following procedure to start HG-T Configuration Tool.

● Before selecting "Read from sensors", check that the PC and the compatible
communication unit are connected correctly.

● Check that the connected HG-TC□ controller (master unit) is turned ON.

5.2.1 Starting by loading the settings from USB communication unit

1. On the "Start menu" dialog box, select "Read from sensors" and, after selecting the
connected communication unit in the “Communication unit being connected” display area,
click the [Start] button.

2. After configuration information and other settings are loaded from each HG-T series
controller, the main window is displayed.

5.2 Starting by Loading the Settings from Communication Unit
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3. The startup procedure is completed.

5.2.2 Starting by loading the settings from RS-485 communication unit

No address is set for the SC-HG1-485 communication unit connected to the PC, so you must
conduct serial communication unit searches. The procedure is as below.

Communication Protocol Setting: Starting by Loading Settings through
MODBUS

1. A question mark is displayed in the “Communication unit being connected” area as an

unknown COM port. Click " ".

5.2 Starting by Loading the Settings from Communication Unit
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2. The "Serial communication unit search" dialog box will be displayed.

● Set the communication protocol between the SC-HG1-485 communication unit and PC to
the MODBUS communication protocol. This setting can be confirmed by the
communication switch located on the side of the target SC-HG1-485 communication unit.

SW No. Name Function

1 Communication protocol setting
0: MODBUS
1: MEWTOCOL

3. Click the [Address] button on the right of ”Device address”, and the "Detect address" dialog
box will be displayed. Select the check box of the address to be specified and then click
anywhere outside the dialog box.

5.2 Starting by Loading the Settings from Communication Unit
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Use the “Address” setting switch on the target SC-HG1-485 communication unit to check
the address setting of the communication unit.

4. Set a desired baud rate by selecting it from the drop-down list.

Use the “Baud rate” setting switch on the target SC-HG1-485 communication unit to check
the baud rate setting of the communication unit.

5.2 Starting by Loading the Settings from Communication Unit
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Name Function

Baud rate setting switch

0: 19,200 bps
1: 38,400 bps
2: 57,600 bps
3: 115,200 bps
4: 1,200 bps
5: 2,400 bps
6: 4,800 bps
7: 9,600 bps

5. Set a desired transfer mode by selecting it from the drop-down list.

Use communication switch [2] on the target SC-HG1-485 communication unit to check the
transfer mode setting of the communication unit.

5.2 Starting by Loading the Settings from Communication Unit
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SW
NO.

Name Function

2 Transfer mode setting
0: RTU

1: ASCⅡ

6. Set a desired parity check value by selecting it from the drop-down list.

Use communication switches [3] and [4] on the target SC-HG1-485 communication unit to
check the parity check setting of the communication unit.

5.2 Starting by Loading the Settings from Communication Unit
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SW
NO.

Name Function

3
Parity check setting (SW3: High order SW4:
Low order)

00: EVEN
01: ODD
10: NONE
11: Setting prohibited

4

7. Set a desired stop bit length by selecting it from the drop-down list.

Use communication switch [5] on the target SC-HG1-485 communication unit to check the
stop bit length setting of the communication unit.

SW
NO.

Name Function

5 Stop bit length setting
0: 1bit
1: 2bit

8. When you have finished setting up the tool software, click the [Search] button. A
confirmation message will be displayed. Click the [Yes] button.

5.2 Starting by Loading the Settings from Communication Unit
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9. If the communication is successful, a completion message will be displayed. Click the [OK]
button.

10.The target SC-HG1-485 communication unit will be displayed in the “Sensor being
connected” area. Select the communication unit by clicking it and then click the [Start]
button.

11. After configuration information and other settings are loaded from each HG-T series
controller, the main window is displayed.

5.2 Starting by Loading the Settings from Communication Unit
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12.The startup procedure is completed.

Communication Protocol Setting: Starting by Loading Settings through
MEWTOCOL

1. The SC-HG1-485 communication unit will be displayed as an unknown COM port in the

“Communication unit being connected” area. Click " ".

2. The "Serial communication unit search" dialog box will be displayed.

5.2 Starting by Loading the Settings from Communication Unit
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● Set the communication protocol between the SC-HG1-485 communication unit and PC to
“MEWTOCOL”. This setting can be confirmed by the communication switch located on the
side of the target SC-HG1-485 communication unit.

SW No. Name Function

1 Communication protocol setting
0: MODBUS
1: MEWTOCOL

3. Click the [Address] button on the right of ”Device address” to display the "Detect address"
dialog box. Select the check box of the address to be specified and then click anywhere
outside the dialog box.

5.2 Starting by Loading the Settings from Communication Unit
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Use the “Address” setting switch on the target SC-HG1-485 communication unit to check
the address setting of the communication unit.

4. Set a desired baud rate by selecting it from the drop-down list.

Use the “Baud rate” setting switch on the target SC-HG1-485 communication unit to check
the baud rate setting of the communication unit.

5.2 Starting by Loading the Settings from Communication Unit
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Name Function

Baud rate setting switch

0: 19,200 bps
1: 38,400 bps
2: 57,600 bps
3: 115,200 bps
4: 1,200 bps
5: 2,400 bps
6: 4,800 bps
7: 9,600 bps

5. Set a desired data length by selecting it from the drop-down list.

Use communication switch [2] on the target SC-HG1-485 communication unit to check the
data length setting of the communication unit.

5.2 Starting by Loading the Settings from Communication Unit
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SW
NO.

Name Function

2 Data bit setting
0: 8bit
1: 7bit

6. Set a desired parity check value by selecting it from the drop-down list.

Use communication switches [3] and [4] on the target SC-HG1-485 communication unit to
check the parity check setting of the communication unit.

5.2 Starting by Loading the Settings from Communication Unit
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SW
NO.

Name Function

3
Parity check setting (SW3: High order SW4:
Low order)

00: EVEN
01: ODD
10: NONE
11: Setting prohibited

4

7. Set a desired stop bit length by selecting it from the drop-down list.

Use communication switch [5] on the target SC-HG1-485 communication unit to check the
stop bit length setting of the communication unit.

SW
NO.

Name Function

5 Stop bit length setting
0: 1bit
1: 2bit

8. When you have finished setting up the tool software, click the [Search] button. A
confirmation message will be displayed. Click the [Yes] button.

5.2 Starting by Loading the Settings from Communication Unit
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9. If the communication is successful, a completion message will be displayed. Click the [OK]
button.

10.The target SC-HG1-485 communication unit will be displayed in the “Connecting sensors”
area. Select the communication unit by clicking it and then click the [Start] button.

11. After configuration information and other settings are loaded from each HG-T series
controller, the main window is displayed.

5.2 Starting by Loading the Settings from Communication Unit
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12.The startup procedure is completed.

5.2 Starting by Loading the Settings from Communication Unit
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5.3 Exiting HG-T Configuration Tool

Use one of the following methods to exit HG-T Configuration Tool.

● If the settings have been changed, be sure to save the configuration file before exiting the
software. If the software is exited without saving the configuration file, the changes will be
discarded.

● Click the [ Close] button in the top right corner of the tool software window.
 

(Note 1) If the configuration file has not been saved, a confirmation window like the one shown above will be
displayed, asking whether to save the configuration file. If [No] button is clicked, the software will be
exited without saving the configuration file.

 

5.3 Exiting HG-T Configuration Tool
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● The following methods can also be used to exit HG-T Configuration Tool.
• Using the menu bar

On the menu bar, select File>Exit.
● •

• - Using the Quick Access Toolbar
On the Quick Access Toolbar, click the HG-T Configuration Tool icon and then select
"Close".

5.3 Exiting HG-T Configuration Tool
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6.1 Main Window

Name Function Reference section

1 Menu bar Displays the menus of each function used by HG-T
Configuration Tool. "6.2 Menu bar"

2 Quick Access
Toolbar

Allows the user to place operation icons for various
functions in order to quickly execute frequently used
functions such as "New", "Save", and "Copy".

"6.3 Quick Access
Toolbar"

3 Title bar
Shows the name of the tool software. When a
configuration file is saved or opened, the name of the
configuration file is indicated.

―

4 Connected units
window

Displays a list of communication units and controllers that
are being connected or edited.

"6.4 Connected Units
Window"

5 "Monitor" tab
Allows the user to monitor the light waveforms received
by the selected controller and the status of each input
terminal.

"6.5 "Monitor" tab"

6 "Settings" tab Allows the user to set up the selected controller. "6.6 "Settings" tab"

7 "Device
information" tab

Displays device information for the selected
communication unit and controllers.

"6.7 "Device information"
tab"

6.1 Main Window
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6.2 Menu bar

This section introduces the functions that can be set on the menu bar.

6.2.1 File Menu

This menu allows the user to set operations and options related to configuration files, and
language.
The following items can be selected.

New

This item allows the user to create a new configuration file.
On the menu bar, select File>New. (Shortcut key: Ctrl + N)
For details on the operating procedure, refer to "8.3.1 Creating New Configuration Files".

Open

This item allows the user to open an existing configuration file.
On the menu bar, select File>Open. (Shortcut key: Ctrl + O)
For details on the operating procedure, refer to "8.3.3 Opening Existing Configuration Files".

Save

This item allows the user to overwrite an existing configuration file.
On the menu bar, select File>Save.
The current configuration file will be overwritten. (Shortcut key: Ctrl + S)

Save as

This item allows the user to rename and save the specified file. The operating procedure is as
below.

1. On the menu bar, select File>Save as.

6.2 Menu bar
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2. The "Save as" dialog box will be displayed.
Specify a storage location and file name and then click the [Save] button. [Storage format:
hgt file format (extension : .hgt)]

Read from sensors

The HG-T series configuration information and other settings in the main unit can be read from
the communication unit connected to the PC.
On the menu bar, select File>Read from sensors (R).
In the displayed menu, select the connected communication unit in the “Communication unit
being connected” display area, then click the [Add] button.
For details, refer to "5.2 Starting by Loading the Settings from Communication Unit".

Option

This item allows the user to specify a password when writing the settings to the controller.
Specifying a password prevents functions from being set or changed for the controller.
For details on the operating procedure, refer to "8.5.1 Setting a Password".

● If you have forgotten the password specified in "Option", you can initialize the password.
For details on the operating procedure, refer to "8.5.2 Initializing a Password".

6.2 Menu bar
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Language

This item allows you to switch the display language for HG-T Configuration Tool.
The operating procedure is as below.

1. On the menu bar, select File>Language. (Default: 日本語)

2. You can select "日本語", "English", "中文" or "한국어".
When HG-T Configuration Tool is restarted, the settings will take effect.

Exit

On the menu bar, select File>Exit to close HG-T Configuration Tool. (Shortcut key: Alt + F4)

6.2.2 Edit Menu

This menu allows you to copy the settings of each function set up for a controller or paste a
copied configuration file to another controller.

6.2 Menu bar
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Copy / Paste

The Copy item allows you to copy all the settings of a particular controller and the Paste item
allows you to paste them to another controller.
For details on the operating procedure, refer to "8.4.1 Copying Settings".

Select and Paste

This item allows you to select any desired settings from a particular controller and paste them to
another controller.
For details on the operating procedure, refer to "8.4.3 Selecting and Pasting Copied Settings".

6.2.3 Help Menu

This menu allows you to refer to the manual and check the software version of HG-T
Configuration Tool.

Manual

This item allows you to refer to the manual of HG-T Configuration Tool.

Version information

Select Help>About.

Version information for HG-T Configuration Tool will be displayed.

6.2 Menu bar
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6.3 Quick Access Toolbar

The menu items of functions that are frequently used with HG-T Configuration Tool can be
registered on the Quick Access Toolbar.

Item Name Reference section

"New" "8.3.1 Creating New Configuration Files"

"Open" "8.3.3 Opening Existing Configuration Files"

"Save" "Save"

"Save as" "Save as"

"Read from communication
unit"

"5.2 Starting by Loading the Settings from
Communication Unit"

"Copy" "8.4.1 Copying Settings"

"Paste" "8.4.2 Pasting Copied Settings"

"Select and Paste" "8.4.3 Selecting and Pasting Copied Settings"

"Manual" "6.2.3 Help Menu"

1. Click the [ ] button on the Quick Access Toolbar.

2. Clicking "Save as" displays a tick mark on the left of "Save as " and adds the  icon on
the right side of HG-T Configuration Tool.

6.3 Quick Access Toolbar
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6.4 Connected Units Window

This window displays a list of communication units and controllers that are being connected or
edited.
Communication units, slave controllers, and master controllers are displayed as connected
units on the tree in this order. If you select a master controller or slave controller in the
connected units window when they are in an online state, "Monitor" tab, "Settings" tab, and
"Device information" tab for the selected controller will be enabled.
The connected units window consists of the following components.

6.4 Connected Units Window
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Name Description Reference section

1 Product image icon The image of the connected product is displayed. "6.4.2 Product Image
Icons"

6.4 Connected Units Window
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Name Description Reference section

2 Communication unit
model The model of the connected product is displayed. -

3 Communication unit
label

The label entered in the Device Information tab
window is displayed. -

4 Connection state The connection state of the communication unit and
the PC is displayed. "6.4.1 Connection State"

5 Error icon

An error or alarm that has occurred on the controller
and the number of errors or alarms are displayed.
Click to pop up the device information notification
dialog.

"6.4.3 Error Icons"
"6.5.6 Device Information
Notification Dialog"

6 Connected head type The measurement width of the connected sensor
head is displayed. -

7 Controller model The model of the controller is displayed. -

8 Output state The output state of the controller is displayed. "6.4.4 Output State"

9 Master unit
identification This is only displayed for master controllers. -

10 Measured value The measured value of the controller is displayed. -

11 Calculation type (for
master units only)

The application set in calculation mode for the master
controller is displayed. -

12 [Edit connected
configuration] button

This button is used to add or remove controllers to be
connected. Use this button only in offline setting
mode.

"8.3.4 Editing Connection
Configuration"

13 [Add] button/[Delete]
button

These buttons are used to add and delete
communication units in the connected units window,
respectively.

"6.4.5 Add and Delete
Buttons for
Communication Unit"

14 Online unit list
This list indicates a state in which the communication
unit and the PC are actually communicating with each
other.

－

15 Offline unit list This list indicates a state in which there are only
settings in the PC and there is no actual machine. -

6.4.1 Connection State

The connection state of the communication unit and the PC is displayed as below.

Connected Disconnected Offline

Can communicate with
communication unit

Cannot communicate with
communication unit

Only settings in the PC and no
actual machine

6.4.2 Product Image Icons

The connected controllers and communication unit are displayed as product images.

6.4 Connected Units Window
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If an alarm or error is detected, the corresponding icon will be displayed within the image of the
unit.

Display Description

HG-T master controller
HG-TC101 / HG-TC101-P

HG-T slave controller
HG-T111 / HG-T111-P / HG-T113

USB communication unit
SC-HG1-USB

RS-485 communication unit
SC-HG1-485

6.4.3 Error Icons

If an error occurs on the controller or the specified alarm conditions are satisfied, one of the
following error icons will be displayed. The number of errors or alarms that occur at the same
time is also displayed inside the red square on the top right of the icon. Click the icon to start
the "Device information notification dialog".

Display Description

An error has occurred on the controller.

The specified alarm has been detected in the controller.

The number of generated errors/alarms is displayed.

6.4.4 Output State

The output states of connected controllers are displayed as below.

Display State Condition

LOW The measured value falls below the LOW set value.

GO The measured value falls within the set value range.

HIGH The measured value exceeds the HIGH set value.

Data indeterminate Correct measurements cannot be made (there is no
abnormality).

6.4 Connected Units Window
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Display State Condition

Out of display range (+) The measured value exceeds +199.999.

Out of display range (-) The measured value falls below -199.999.

Alarm An alarm has occurred.

Error An error has occurred.

6.4.5 Add and Delete Buttons for Communication Unit

Add

This button is used to add communication units to the connected units window.
Clicking [Add] displays a sensor addition menu.
For details on how to add communication units, refer to "8.3.1 Creating New Configuration
Files".

Delete

This button is used to delete communication units from the connected units window.
The procedure for deleting communication units is as described below.

1. Select a connection configuration to be deleted from the connected units window and then
click [Delete].

6.4 Connected Units Window
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2. A confirmation message will be displayed. Click [Yes].

3. The selected connection configuration has been deleted.

6.4 Connected Units Window
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6.5 "Monitor" tab

This tab allows the user to monitor the light waveforms received by the selected controller or
the status of each I/O terminal.

6.5.1 Monitor Tab Window

Name Description Reference section

1
Received light
waveform monitor /
measured value
monitor

Received light waveform monitor or measured
value logging monitor is displayed.

"6.5.2 Received Light
Waveform Monitor"
"6.5.3 Measured Value
Monitor"

2 Monitor selector The display can be changed to the received light
waveform monitor or measured value monitor. ―

3 [Export as Image] /
[Export as CSV]

Received light waves or measured values are
output as image or CSV data.

"6.5.4 Export as Image /
Export as CSV"

4 I/O monitor The ON/OFF state of each function is displayed. "6.5.5 I/O Monitor"

6.5.2 Received Light Waveform Monitor

This area displays the state of the light waveforms received by the selected controller, judgment
level waveforms, and edge positions.

6.5 "Monitor" tab
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Name Description

1 Vertical axis The amount of light received is displayed.

2 Horizontal axis The measurement range of the sensor head is displayed.

3 Received light
waveform

Waveforms are displayed by connecting each measured amount of received light
with a line.

4 Judgment level
waveform

Waveforms are displayed by connecting each measured amount of received light at
the specified judgment level with a line. If the amount of light received falls below
the judgment level, the light will be judged to be intercepted and the edge position
will be calculated.

5 Edge position The edge position of the measured object that is inserted is displayed as a straight
line.

6 Measured value The area from the top or bottom to the edge position is displayed as an arrow line.
The area indicated by the arrow line is the value measured by the sensor head.

6.5.3 Measured Value Monitor

The measured value in the selected controller is displayed. The update cycle can be changed
to a desired setting. This monitor can be used for measured value logging.

Name Description

1 Vertical axis Measured values are indicated.

6.5 "Monitor" tab
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Name Description

2 Horizontal axis The elapsed time from the start of logging is shown. The graph scrolls horizontally
as the elapsed time increases.

3 Measured value
waveform The waveform is created by connecting measured values with a line.

4 Update cycle setting The interval of the measured value logging can be set.

5 Logging operation

Used to perform measured value logging operations.

: Pauses logging.

: Stops logging.(Note 1)

: Starts logging. (Pressing this while logging is paused resumes logging.)

6 Slider By moving the slider, you can check the past measurement waveform outside the
display area.

 

(Note 1) When logging is stopped, a confirmation message appears and the data can be output as CSV. If CSV
data is not output, the logging data will not be saved.

 

● If an abnormality occurs during logging, the following will be displayed.

Name Description

1
Data loss
Indeterminate data

When data is lost or becomes indeterminate, the zone where such a
problem has occurred is displayed as a gray background.

2
Error / alarm occurrence
Out of display range

When an error or alarm occurs on the device or data goes beyond or falls
below the display range, the zone where such a problem has occurred is
displayed as a red background.

6.5.4 Export as Image / Export as CSV

Information displayed in the graph window can be output as image or CSV.

Export as Image

The graph displayed in the window can be output as image data (format: PNG).

6.5 "Monitor" tab
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1. Click [Export as Image].

2. The "Save as" dialog box will be displayed.
Specify a storage location and file name and then click [Save].

3. Images will be output in PNG format to the specified storage location.

Export as CSV

Information of the graph displayed in the window can be output as CSV data.
When the received light waveform monitor has been selected, the “array number” and the
“amount of received light” are output.

6.5 "Monitor" tab
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When the measured value monitor has been selected, the “refreshing interval,” the “acquisition
time” and “measured value” are output.

1. Click [Export as CSV].

2. The "Save as" dialog box will be displayed.
Specify a storage location and file name and then click [Save].

3. Data will be output in CSV format to the specified storage location.

6.5 "Monitor" tab
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6.5.5 I/O Monitor

The I/O monitor displays the ON/OFF state of each function or the preset ON/OFF state for the
connected controller.
Each indicator turns ON when the output or input turns ON. The icon on the right side of the
indicator indicates the color of the cable.

● The monitor is not influenced by output operation settings.

6.5.6 Device Information Notification Dialog

■ Error
If an error occurs on the controller, error information like the following example will be displayed.

Name Description

1 Error message Indicates an error that has occurred on the current controller

6.5 "Monitor" tab
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Name Description

2 Error code Indicates the error code of the error that has occurred

3 Action Indicates the action to resolve the error that has occurred

For details on error messages and action methods, refer to "9.1 Error Messages".

■ Alarm
If an alarm occurs on the controller, alarm indication like the following example will be
displayed.

Name Description

1 Alarm message Indicates an alarm that has occurred on the current controller

2 Action Indicates the action to resolve the alarm that has occurred

For details on alarm messages and action methods, refer to "9.2 Alarm Messages".

6.5 "Monitor" tab
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6.6 "Settings" tab

This tab allows the user to set up each parameter for the selected controller.

6.6.1 Settings Tab Window

Name Function Reference section

1 Received light
waveform monitor

The state of received light waveforms is displayed.
The vertical axis indicates the amount of light
received and the horizontal axis indicates the
measurement range of the sensor head.

"6.5.2 Received Light
Waveform Monitor"

2 Configuration parameter
area

This area displays the parameters that can be set
for the HG-T series controllers. Each parameter
can be checked and edited.
When the tool software is started, this area is
displayed in simple setting mode (in which only
general parameters are displayed).

-

3 "Advanced settings
mode" check box

Selecting this check box displays all settable
parameters in the configuration parameter area so
that more detailed settings can be specified.

"6.6.2 List of Configuration
Parameters"

4 [Write] button
Clicking this button writes the parameter settings
in the configuration parameter area to the
controller.

"7.7.1 Writing Procedure"

5 [Read] button
Clicking this button reads the parameter settings
from the controller and reflects them into the
configuration parameter area.

-

6.6 "Settings" tab
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Name Function Reference section

6 "Write automatically"
check box

When any parameter in the configuration
parameter area is changed, the changed settings
are automatically written to the main unit.

-

6.6.2 List of Configuration Parameters

The following list shows the parameters and items that can be set with HG-T Configuration
Tool.
For details on each parameter, refer to the HG-T User's Manual.

Configuration parameter Outline
Advanced

settings mode
(Note 2)

Sensitivity
setting

Beam axis adjustment /
Reference waveform
registration

This parameter allows the user to adjust the
beam axis and register reference waveforms.

Manual sensitivity
adjustment ON: User setting / OFF: Default value

Judgment level [%] This item allows the user to set a judgment level
when manual sensitivity adjustment is set to ON.

Judgment filter This item allows the user to set a judgment filter
when manual sensitivity adjustment is set to ON.

Measureme
nt settings

Operation mode This parameter allows the user to set the
operation mode.

Measurement
direction

This item sets the direction in which the
measured object is inserted when the operation
mode requires direction settings.

Measured value
reversal

This item turns ON when the measured value
reversal function is used.
Default：OFF

Edge position
This item is used when the user assigned edge
detection mode is selected.
Assigned edge 1 and edge 2.

Sampling cycle This parameter sets the sampling cycle of the
sensor head. 〇

Average count This parameter sets an average count (response
time).

Correction
settings

Preset This parameter sets ON / OFF for preset.

Correction
value(Note 1)

This item sets a preset value when Preset is set
to ON.

Preset data selection This parameter sets target data for preset. 〇

Value calculation This parameter sets ON / OFF for calculation. 〇

Calculation method This item is used to select from five methods
such as the minimum value and maximum value. 〇

Tab cancel This parameter turns ON when the tab cancel
function is specified.

6.6 "Settings" tab
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Configuration parameter Outline
Advanced

settings mode
(Note 2)

Tab judgment
threshold

This is one of the setting parameters of the tab
cancel function.
Default: 1.000 mm

Tab detection count
This is one of the setting parameters of the tab
cancel function.
Default: 17

Hold settings This parameter sets each hold function. 〇

Trigger mode This item sets trigger mode for each hold
function. 〇

Calibration This parameter performs a calibration.

Operation
setting

Threshold

HIGH set value
[mm]

This item sets the HIGH set value to any desired
value.

LOW set value
[mm]

This item sets the LOW set value to any desired
value.

Teaching This item performs teaching.

Hysteresis [mm] This item sets the hysteresis to be used for
teaching. 〇

Digital I/O

IN1 / IN2 / IN3 This item sets the input terminal function.

Simultaneous input This item sets ON / OFF for simultaneous input. 〇

OUT1 / OUT2 /
OUT3 This item sets the output terminal function.

Output type This item sets N.O. or N.C.

Output delay timer This item sets an output delay timer. 〇

Timeout value This item sets a timeout value for the output
delay timer. 〇

Analog output

Output type This item sets voltage output or current output.

Scaling ON: User setting / OFF: Default value 〇

Upper limit value [mm]
This item sets the upper limit value of analog scaling when scaling is
set to ON.

〇

Lower limit value [mm]
This item sets the lower limit value of analog scaling when scaling is
set to ON.

〇

Alarm 〇

Alarm delay count
[number] This item sets an alarm delay count. 〇

Alarm output This item sets the output state at the time of
measurement alarm 1 occurrence. 〇

Dirt check This item sets the dirt check function. 〇

6.6 "Settings" tab

6-26 WUME-HGTCT-7



Configuration parameter Outline
Advanced

settings mode
(Note 2)

Threshold This item sets threshold values for the dirt check
function when user settings are specified. 〇

Connected units
count check

This item sets the connected units count check
function. 〇

Reverse insertion
check

This item sets the reverse insertion check
function. 〇

Configuratio
n

Bank settings

Item to be read and
written

This item sets the item to be saved to or loaded
from each bank.

Bank operation This item saves or loads the set item to or from
the bank.

EEPROM storage 〇

Preset save This item sets ON / OFF for preset storage in
EEPROM. 〇

Reference
waveform save

This item sets reference waveform storage in
EEPROM through host communication. 〇

Interference prevention This parameter sets ON / OFF for the
interference prevention function. 〇

Number of digits
displayed

This parameter sets the number of digits to be
displayed. 〇

Eco mode This parameter sets ON / OFF for Eco mode. 〇

Auto key lock ON: Manual / OFF: Auto setting 〇

 

(Note 1) The parameter name changes according to the preset ON / OFF setting. (ON: Target value / OFF:
Correction value)

(Note 2) Parameters where 〇 is marked in the "Advanced settings mode" column are displayed and can be set
when the "Advanced settings mode"check box at the bottom of the "Settings" tab window is selected.

 

6.6 "Settings" tab
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6.7 "Device information" tab

Clicking the "Device information" tab allows the user to check device information for the
selected controller and communication unit and to initialize the controller and set a label.

Name Description

1
Device information
(Note 1)

[Controller]
Label, model name, type, software version, and connected head

[Communication unit]
● SC-HG1-USB

Label, model name, interface, serial number, and software version
● SC-HG1-485

Label, model, interface, port number, device address, serial number, and
software version

2
[Initialization] button
(Note 2) This button resets the controller to its factory default state.(Note 2)

3 Maintenance
information The cumulative operating hours of the controller and sensor head are displayed.

4 [Information update]
button Maintenance information is updated to the latest information.

6.7 "Device information" tab
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(Note 1) For details on how to set a label, refer to "8.2 Labeling".
(Note 2) For details on how to initialize a controller, refer to "7.9 Initialization".
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(MEMO)
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7 Setting up the Main Unit
The "Settings" tab can be used to set up the main unit.

7.1  Flow of Operations up to Setup Completion .......................................7-2
7.2  Adjusting the Beam Axis and Registering Reference Waveforms ......7-3
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7.1 Flow of Operations up to Setup Completion

This section explains the flow of HG-T Configuration Tool operations up to the completion of
main unit setup.
1. Preparation

Download the tool software from our website, and install the software by following the
installation procedure.
"4.1 Installation"

2. Start

Start up HG-T Configuration Tool.
"5.1 Starting HG-T Configuration Tool"

3. Read

Using the compatible communication tool, load the HG-T series main unit settings to the PC.
"5.2 Starting by Loading the Settings from Communication Unit"

4. Confirming the waveform

Using the "Monitor" tab or "Settings " tab, confirm the waveform.
"6.5 "Monitor" tab"
"6.6 "Settings" tab"

5. Setting up the functions

Using the "Settings" tab, set or change the parameters in the HG-T series main unit.
"6.6.2 List of Configuration Parameters"

6. Write

After completing the function setting, write the settings to the controller by following the
specified procedure.
"7.7 Writing Parameters to Main Unit"

7. Saving the configuration file

After completing the setting, save the configuration file in the PC for safekeeping.
"6.2.1 File Menu"
"Save as"

7.1 Flow of Operations up to Setup Completion
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7.2 Adjusting the Beam Axis and Registering Reference Waveforms

Use this procedure to check the beam axis of the connected controller and register reference
waveforms.

The operating procedure is as below.

1. Click the [Detail] button on the right side of Beam axis adjustment / reference waveform
registration to display the following window.

If the beam axis is misaligned, the waveform will be displayed in red. The adjustment
method is displayed on the top left of the window. Move the emitter or receiver upward,
downward, rightward, or leftward according to the instruction displayed in the dialog box.
For details on how to adjust the beam axis, refer to "Adjusting the Beam Axis" in the HG-T
series User's Manual.

7.2 Adjusting the Beam Axis and Registering Reference Waveforms
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2. If the beam axis is aligned according to the displayed adjustment method, the waveform will
be displayed in blue and the message "Reference waveform can be registered" will be
displayed.

3. If you successively register a reference waveform, click the [Register reference waveform]
button. The received light waveform displayed in the graph window will be registered as the
reference waveform.
(If you do not register a reference waveform, click the [Cancel] button. The display will be
returned to the main window.)

When the registration is completed, the message "Reference waveform has been
registered" will be displayed. Clicking [OK] button closes the message window.

7.2 Adjusting the Beam Axis and Registering Reference Waveforms
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7.3 Adjusting Sensitivity

If the measured object that is inserted is a transparent body or if there is a risk of foreign objects
contamination in the environment, you can change the judgment level and judgment filter for the
sensor head that is connected.
If Sensitivity setting is set to OFF, the judgment level and judgment filter are set to their
respective default values. To adjust them, set Sensitivity setting to ON, so that you can change
the judgment level and judgment filter.

1. Slide the "Sensitivity setting" switch from OFF to ON. (Default: OFF)

2. For stable measurement of objects with high transmittance, you must increase the
judgment level. For the judgment level, you can use either numerical input or slider input.

Configuration parameter Setting range Default value

Judgment level [%] 10 to 90 (%) 25

3. To prevent malfunctions due to foreign objects contamination or other problems, you must
increase the value of the judgment filter. For the judgment filter, you can use either
numerical input or slider input.

7.3 Adjusting Sensitivity
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For stable measurement of small objects, you can measure them stably by reducing the
value of the judgment filter.

Configuration parameter Setting range Default value

Filter strength 3 to 50 9

7.3 Adjusting Sensitivity
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7.4 Performing Measurement Settings

You can set the operation mode, insertion direction and average count according to the shape
of the measured object or application.

7.4.1 Operation Mode

Set the operation mode according to the method of measuring the workpieces.
(Default: Auto edge detection mode)

Setting item Description

"Auto edge detection mode"
This mode automatically recognizes the direction in which the measured object
enters the measurement area of the sensor head (TOP or BOTTOM side). The
distance from the edge of the side where the measured object enters the
measurement area to the edge of the measured object is measured.

"Edge detection mode"
When the direction in which the measured object enters the measurement area
of the sensor head is specified as the TOP or BOTTOM side, this mode
measures the distance from the TOP or BOTTOM side of the measurement area
to the edge of the measured object.

"Outer diameter / width
detection mode" This mode measures the outer diameter or width of the measured object.

"Inner diameter/gap
detection mode" This mode measures the inner diameter or gap of the measured object.

"Center location detection
mode"

When an object such as a pin is measured, this mode measures the distance
from either the TOP or BOTTOM side edge to the center of the measured object.

"User assigned edge
detection mode"

This mode measures the distance between the edges of the two points that are
optionally selected from a number of detected edges or the distance from the
TOP or BOTTOM position to the optionally assigned edge position.

7.4 Performing Measurement Settings
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● When "Edge detection mode" is selected, the "reverse insertion check" function can be used.
The reverse insertion check function generates an alarm when the measured object is inserted
in a direction different from the specified insertion direction.

7.4 Performing Measurement Settings
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7.5 Performing Teaching

This function allows you to set HIGH and LOW set values automatically.
For the teaching method, you can select 1-point teaching, 2-point teaching, or 3-point teaching.

1. Click the [ Teaching ] button.

2. The "Teaching" dialog box will be displayed. Select a teaching method to be set.

When performing teaching, check the setting for the direction of insertion by viewing
"Measurement settings"－"Measurement direction".

● When the operation mode has been set to "Auto edge detection mode", the "Threshold"
parameter will be displayed as shown below.

Mode other than auto edge
detection mode

Auto edge detection mode

 

(Note 1) If the threshold values are changed
using the threshold setting, it is
necessary to set either TOP or
BOTTOM as the reference point.

 

7.5 Performing Teaching
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7.5.1 1-point Teaching

1. Enter a tolerance to be set.
The judgment value of the master workpiece plus the tolerance can be set as the HIGH set
value and the judgment value of the master workpiece minus the tolerance can be set as
the LOW set value.

2. With the master workpiece measured, click the [Fix the measured value] button.

3. The HIGH and LOW set values will be set. By entering a numerical value, you can adjust
the HIGH or LOW set value within the range (between the HIGH and LOW set values).

4. If you click the [Accept] button, the values set for teaching will be reflected in the
configuration parameters.

7.5 Performing Teaching
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● To reset the HIGH and LOW set values that have been set, click the [Reset] button in the lower
right part of the "Teaching" window. The HIGH and LOW set values will be reset.

7.5.2 2-point Teaching

1. Measure the first workpiece and click the [Fix the measured value] button for the first
workpiece.

2. Measure the second workpiece and click the [Fix the measured value] button for the second
workpiece.

7.5 Performing Teaching
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3. The HIGH and LOW set values will be set. By entering a numerical value, you can adjust
the HIGH or LOW set value within the range (between the HIGH and LOW set values).

4. If you click the [Accept] button, the values set for teaching will be reflected in the
configuration parameters.

7.5.3 3-point Teaching

1. Measure a LOW defective workpiece and click the [Fix the measured value] button.

2. Measure a good workpiece and click the [Fix the measured value] button.

7.5 Performing Teaching
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3. Measure a HIGH defective workpiece and click the [Fix the measured value] button.

4. The HIGH and LOW set values will be set. By entering a numerical value, you can adjust
the HIGH or LOW set value within the range (between the HIGH and LOW set values).

5. If you click the [Accept] button, the values set for teaching will be reflected in the
configuration parameters.

7.5 Performing Teaching
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7.6 Performing Calibration

By performing a calibration, you can reduce installation errors when replacing the sensor head,
for example.

1. Select the "Advanced settings mode" check box.

2. Set the "Calibration" switch from OFF to ON. (Default: OFF)

3. The "Calibration settings" window will be displayed. Insert the first workpiece between the
emitter and receiver of the sensor head, and click the [Fix the measured value] button when
the workpiece is at any desired position.

4. Enter a target value for the first workpiece.

7.6 Performing Calibration
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Item Setting range Default value

Target value -199.999 to 199.999 (mm) 0.000

5. Insert the second workpiece between the emitter and receiver of the sensor head, and click
the [Fix the measured value] button when the workpiece is at any desired position.

To change the measured value, click [Fix the measured value] button and cancel the value.
After changing the position of the workpiece, click the [Fix the measured value] button.

6. Enter a target value for the second workpiece.

Item Setting range Default value

Target value -199.999 to 199.999 (mm) 10.000

7. Click the [Finalize] button. A calibration will be executed.

8. A message is displayed while a calibration is being executed. When the message
disappears, the calibration is completed.

7.6 Performing Calibration
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9. After the calibration is complete, check that the Calibration switch is set to ON.

Note: Clicking the [Correction screen ] button displays the "Calibration" dialog box again, so
that you can perform a calibration again. (The dialog box will be reset to the default state.)

7.6 Performing Calibration
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7.7 Writing Parameters to Main Unit

If settings have been changed with HG-T Configuration Tool, the settings can be written to the
HG-T series controller.

● Before writing the settings, check if the PC and the HG-T series controller are correctly
connected.

● If the "Write automatically" check box is selected, the settings will be sent to the specified
controller at the same time as when the settings are changed.

7.7.1 Writing Procedure

1. In the connected units window, select the controller to which the setting data is to be
written.

2. Click the [Write] button.

3. The following confirmation window will be displayed. Clicking [OK] writes the setting data to
the specified controller.

7.7 Writing Parameters to Main Unit
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7.7.2 If Parameters Cannot be Written

■ Situation
If you click the [Write] button when the controller write-protection function is enabled, a
message will be displayed, indicating that the setting data cannot be written to the controller.

■ Action method
Disabling the write lock function enables the data to be written. The procedure is explained
below.

1. On the menu bar, click File>Option to display the "Option" window. In the "Option" window,
clear the "Enable write lock function" check box.

2. The "Password input" window will be displayed. Enter a password and click the [OK] button.

3. The display will be returned to the "Option" window. Check that the "Enable write lock
function" check box is not selected and then click the [OK] button.

4. A completion message will be displayed, indicating that the write lock function has been
disabled.

7.7 Writing Parameters to Main Unit
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If you have disabled the write lock function, we recommend that this function be enabled
again.

7.7 Writing Parameters to Main Unit
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7.8 Performing Bank Operation

You can write and read the HIGH and LOW set values (or other setting data) to / from the
specified bank (1 to 3) for the selected controller. You can use the bank function to write
settings for an object to be measured to a bank beforehand and easily read the settings when
needed.
The operating procedure is as below.

1. Select a setting item to be loaded or saved from / to a bank.

Bank save selection Function

HIGH set value and LOW set value
(THRS) Selects the HIGH set value and LOW set value

HIGH set value, LOW set value, preset
value, sensitivity adjustment, judgment
level, and judgment filter
(THRS.PR)

Selects the HIGH set value, LOW set value, preset value,
sensitivity adjustment, judgment level, and judgment filter

All items (ALL) Selects all items

2. Click the [Bank operation] button.

3. The "Bank operation" window will be displayed. Select a bank that data is to be read from
or written to.

7.8 Performing Bank Operation
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4. Check the selected bank and click the [Read] button or [Write] button.

7.8 Performing Bank Operation
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7.9 Initialization

If a controller is selected, the [Initialize the controller] button will be displayed in the "Device
information" tab. Clicking the [Initialize the controller] button initializes the controller to the
factory default settings.

1. Select a desired controller in the sensor list and click the "Device information" tab.

2. Click the [Initialize the controller] button.

3. A confirmation message will be displayed. Click the [Yes] button.

7.9 Initialization
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4. When the controller has been initialized, the following completion window is displayed.

7.9 Initialization
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8.1 Monitoring Multiple Controllers

Light waveforms received by multiple controllers can be monitored simultaneously.
The operating procedure is as below.

1. In the “connected units window”, click the communication unit connected to multiple
controllers to be monitored.

2. Click "Monitor" tab.

3. Click the first controller to be monitored and drag and drop it into the area in the "Monitor"
tab window.

4. The monitor screen of the first controller will be displayed in the "Monitor" tab window.

8.1 Monitoring Multiple Controllers
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5. Click the second controller to be monitored and drag and drop it into the area in the
"Monitor" tab window in the same way as above.

6. The monitor screens of the two controllers will be displayed in the "Monitor" tab window.

● When multiple controllers are monitored, the display of received light waveforms can be
reversed. Clicking the "Reverse the waveform" check box in each monitor screen reverses
the display of the received light waveform.

8.1 Monitoring Multiple Controllers
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● Clicking the trash icon in the screen of the monitored controller displays a confirmation
message. Selecting [Yes] deletes the monitor screen of the target controller.

Notes: 1) Simultaneously monitoring a number of controllers delays monitor updating.
2): Multiple controllers cannot be monitored simultaneously between different communication
units.

8.1 Monitoring Multiple Controllers
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8.2 Labeling

The label of the controller or communication unit selected in the connected units window can be
changed.

1. In the connected units window, select a desired communication unit or controller and click
the "Device information" tab.

2. Information for the selected device will be displayed. If necessary, enter a label name.

3. After entering any desired label name, press the Enter key. A confirmation message
window will be displayed. Click the [Yes] button.

8.2 Labeling
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4. When processing is complete, the label field of the controller or communication unit in the
sensor list will be changed to the name that was entered.

Note: Labels of communication units are managed by the tool software in the PC. If the tool
software is reinstalled or the communication unit is connected to another PC, the set label
will not be retained.

● When changing the label name of a controller, you can enter the following characters:
<Characters that can be entered: A to Z, 0 to 9, *, +, －, <, >, \, <space>> (Number of
characters that can be entered: Six half-width characters)

8.2 Labeling
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8.3 Offline Setting

Settings can be specified on a PC (offline) that is not connected to HG-T series controllers. This
section explains how to create a new configuration file in offline setting mode and how to open
and edit an existing configuration file in offline setting mode.

8.3.1 Creating New Configuration Files

Use the following procedure to create a new configuration file.

1. In the "Start menu" dialog box, select "Create a new file" and then click the [Start] button.

2. A communication unit addition menu will be displayed. Select a communication unit to be
used and click the [Add] button. Note: A communication unit can also be added by double-
clicking the icon of a communication unit to be added.

8.3 Offline Setting
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3. A controller addition menu will be displayed. Select a controller (master unit) to be used and
then drag and drop it into the "Connected configuration" area.

4. After selecting the master unit, select a slave unit and then drag and drop it into the
"Connected configuration" area.

● Up to 14 controllers (slave units) can be dragged and dropped into the "Connected
configuration" area.

● To delete a selected controller from the configuration, click the " " icon for the
controller. Deleting a master unit from the configuration also deletes all the slave units
connected to the master unit.

8.3 Offline Setting
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5. After selecting all the controllers to be used, click the [Finalize] button.

6. The main window will be displayed in offline setting mode.

7. After all the controllers to be used have been set up, click File>Save as on the menu bar
and save the configuration file.

8.3 Offline Setting
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8.3.2 Writing Configuration Files to Controller

If a configuration file that has been created in offline setting mode is reflected in a HG-T series
controller, you must write the configuration file to the HG-T series controller. The procedure is
explained below.

1. Connect the HG-T series controller and the PC. After connecting them, turn ON the HG-T
series controller, select a desired communication unit in the connected units window, and
click the connection state icon.

2. When the connection state icon is clicked, the "Connection" dialog box will be displayed.
The communication units that are currently connected are displayed. Select a desired
communication unit. Then, click the [Finalize] button.

8.3 Offline Setting
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Note ： If the communication unit addition menu is used to select the SC-HG1-485 as the
communication unit to be used, a different operating method will be used. For details on the
operating procedure,"5.2.2 Starting by loading the settings from RS-485 communication
unit" .

3. "The confirmation message "Do you want to write the settings?" "will be displayed. Click the
[Yes] button. The settings will be written to and reflected in the HG-T series controller.

8.3 Offline Setting
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● When the settings are written, if the number of controllers that is specified in the
configuration file in offline mode differs from the actual number of HG-T series controllers
connected to the communication unit, the following confirmation message will be displayed.

Recheck the number of controllers that is specified in the configuration file in offline mode
and the actual number of HG-T series controllers.
If you do not write the settings, click the [No] button.
If you write the settings, click the [Yes] button.
If you write the settings when the number of controllers specified in the configuration file
differs from the actual number of HG-T series controllers, note the following points.
• If the number of controllers that is specified in the configuration file is greater than the

number of HG-T series controllers connected, the settings will be written to the HG-T
series master unit and only the actual slave units sequentially connected to the master
unit. The settings in the configuration file that are for controllers exceeding the actual
number of HG-T series controllers will not be written.

• If the number of controllers that is specified in the configuration file is fewer than the
number of HG-T series controllers connected, the settings will be written to the HG-T
series master unit and the slave units sequentially connected to the master unit that are
the same number as the number of controllers in the configuration file. The settings will
not be written to HG-T series controllers that exceed the number of controllers that is
specified in offline setting mode.

8.3.3 Opening Existing Configuration Files

You can load configuration files created in the past. The procedure is as below.

1. In the "Start menu" dialog box, select "Open a file" and then click the [Start] button.

8.3 Offline Setting
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2. A "file selection" dialog box will be displayed. Select a file to be used and click the [Open]
button.

3. The main window will be displayed in offline setting mode.

8.3.4 Editing Connection Configuration

1. In the connected units window, click the [Edit connected configuration] button.

8.3 Offline Setting
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2. The "Editing connected configuration" dialog box will be displayed.

3. Edit the connection configuration by adding or deleting controllers. After editing the
connection configuration, click the [Finalize] button to reflect the configuration in the
connected units window.

Example: Window with a slave unit (HG-TC111) deleted

8.3 Offline Setting
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8.4 Copying Settings

You can copy the settings of each function set up for a controller and paste the copied settings
to another main unit. (Copying settings)

8.4.1 Copying Settings

1. In the connected units window, select the controller from which you want to copy the
settings.

2. Copy the settings of the controller as below. On the menu bar, select Edit>Copy.
Alternatively, you can right-click and then select "Copy" from the context menu that
appears.
Shortcut key: Ctrl+C

8.4.2 Pasting Copied Settings

1. In the connected units window, select the controller to which you want to paste the copied
settings.

2. Paste the settings of the controller as below. On the menu bar, select Edit>Paste.
Alternatively, you can right-click and then select "Paste" from the context menu that
appears.
Shortcut key: Ctrl+V

8.4 Copying Settings
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8.4.3 Selecting and Pasting Copied Settings

1. Select and paste the copied settings of the controller as below. On the menu bar, select
Edit>Select and Paste.

2. The "Select and Paste" window will be displayed. "In Items to be pasted, "select items that
you want to set.

3. The settings can be pasted to multiple controllers at one time. Select the "Specify more
than one copy destination" check box and select applicable controllers.

8.4 Copying Settings
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4. Clicking the [Paste] button copies the parameters selected in the Settings tab window of the
copy source to the Settings tab window of the copy destination controller.

5. For details on how to write the settings to the HG-T series controller without making any
changes, refer to "7.7 Writing Parameters to Main Unit".

8.4 Copying Settings
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8.5 Protecting Settings with Password

8.5.1 Setting a Password

You can specify a password that is required to write settings to a controller. Specifying a
password prevents functions from being set or changed for the controller.

● When the controller write-protection function is disabled, there is a risk that settings could be
changed by third parties. We recommend that users specify passwords and enable the write-
protection function to prevent third parties from changing the settings.

● Implement strict management to prevent passwords from being forgotten.

1. On the menu bar, select File>Option.

2. The "Option" window will be displayed. Select the "Enable the write lock function" check
box and the "Set a new password" check box and then enter the current password and a
new password. When setting a password for the first time, enter a new password only.
● For passwords, use four half-width alphanumeric characters.
● English alphabets are case-sensitive.

3. For confirmation, enter the password again in the "New password (confirm)" field and then
click the [OK] button.

8.5 Protecting Settings with Password
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When a password has been set, the controller write-protection function is enabled. (No
password is set at the time of shipping.)

8.5.2 Initializing a Password

If you have forgotten your password, initialize the password using the following procedure.

1. In the "Password input" window, click the [Initialize] button.

2. The "Password initialization" window will be displayed. Notify your local dealer of the
request code displayed in the window. Your local dealer will notify you of an initialization
code.

3. After receiving an initialization code, enter the initialization code in the "Password
initialization" window. After entering the code, click the [Initialize] button. The password will
be initialized and the write-protection function will be disabled.

8.5 Protecting Settings with Password
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9.1 Error Messages

One of the messages shown below is displayed in the device notification information section
when an error occurs during setting or measurement.
For the details of the device notification information, refer to "6.5.6 Device Information
Notification Dialog".

● When the HG-T controller manufactured prior to January 2019 is used, some functions will be
restricted. For details, consult your Panasonic representative.

Message Error code Action method

"EEPROM of the controller is damaged." E600 / 610 /
620 Replace the controller.

"EEPROM of the sensor head is damaged." E630 / 640 Replace the sensor head.

"The detection output load has short-circuited
and excessive current is flowing." E700 Turn OFF the power and check the load.

"Laser of the emitter is damaged." E240 Replace the sensor head.

"Communication error between the sensor head
and controller has occurred." E200

Check if the sensor head is correctly
connected.
Check if there is a broken wire in the
connection cable.

"The combination of emitter and receiver is
incorrect." E230 Check the connection state of the sensor

head and controller.

"An error has occurred inside the controller." E900 / 911 /
912 / 920

Turn the power OFF and then ON to initialize
the controller.

"Communication error between connected
controllers has occurred." E120 / 130 Check if the controllers are correctly

connected.

"Number of connected controllers is changed." E160 Check the number of controllers connected.

"NPN output type and PNP output type
controllers are mixed." E100 Standardize the controller type as the NPN

output type or PNP output type.

"Number of slave units is insufficient for the
calculation." E140 / 150

Connect the necessary number of slave units.
Check the settings of the calculation
application.
Set the calculation function to OFF.

"Maximum number of connectable controllers is
exceeded." E110 Check the number of controllers connected.

Important

If an error occurs again after you cleared it, check if excessive vibration is transmitted to the controller or the
sensor head.
If the product still does not operate normally after you check the above, consult our technical support center.

9.1 Error Messages
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9.2 Alarm Messages

One of the messages shown below is displayed in the device notification information section
when an alarm occurs during setting or measurement.
For details on the device information notification, refer to "6.5.6 Device Information Notification
Dialog".

● When the HG-T controller manufactured prior to January 2019 is used, some functions will be
restricted. For details, consult your Panasonic representative.

Message Action method

"Maximum number of detectable edges is
exceeded."

● Check the condition of the workpiece.
● Clean the lenses on the emitter and receiver of the

sensor head.

"Measurement setting: The direction of workpiece
insertion is different from the setting of
measurement direction."

● Match the setting and the direction of workpiece
insertion.

● When inserting workpieces in the reverse direction, set
the reverse insertion check function to OFF.

"The intensity of received light is too much." Check if ambient light hits the light receiving section of the
sensor head.

"Intensity of received light is reduced."

● Check the condition of the workpiece.
● Clean the lenses on the emitter and receiver of the

sensor head.
● Install the emitter and receiver of the sensor head

correctly.
● Check the settings of the alarm / dirt check function.

"The master unit executed the copy operation, but
a copy cannot be produced due to a slave unit
malfunction."

Turn the power OFF and then ON and check that the
slave unit operates normally.

"Communication error between connected
controllers has occurred."

Turn OFF the power, check whether the controllers are
connected correctly, and then turn ON the power again.

Important

If the product still does not operate normally after you cleared the above, consult our technical support center.

9.2 Alarm Messages
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