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Copyright, liability, and warranty

Copyright, liability, and warranty

Copyright and liability

This manual and everything described in it are copyrighted. You may not copy this manual, in
whole or part, without written consent of Panasonic Industry Europe GmbH.

Panasonic Industry Europe pursues a policy of continuous improvement of the design
and performance of its products. Therefore, we reserve the right to change the manual/
product without notice. In no event will Panasonic Industry Europe be liable for direct,
special, incidental, or consequential damage resulting from any defect in the product or its
documentation, even if advised of the possibility of such damages.

Please direct support matters and technical questions to your local Panasonic
representative.

Panasonic Industry Europe GmbH

Caroline-Herschel-Straße 100

85521 Ottobrunn, Germany

Tel: +49 89 45354-1000

Limited warranty

If physical defects caused by distribution are found, Panasonic Industry Europe will replace/
repair the product free of charge. Exceptions include:

• When physical defects are due to different usage/treatment of the product other than
described in the manual.

• When physical defects are due to defective equipment other than the distributed product.

• When physical defects are due to modifications/repairs by someone other than Panasonic
Industry Europe.

• When physical defects are due to natural disasters.
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 Software legal notices

Software legal notices

This product incorporates the following software:

(1) The software developed independently by or for Panasonic Industry Europe GmbH,

(2) the software owned by third party and licensed to Panasonic Industry Europe GmbH,

(3) the software licensed under the GNU General Public License, Version 2.0 (GPL V2.0),

(4) the software licensed under the GNU LESSER General Public License, Version 2.1
(LGPL V2.1), and/or

(5) open source software other than the software licensed under the GPL V2.0 and/or LGPL
V2.1.

The software categorized as (3) - (5) are distributed in the hope that it will be useful, but
WITHOUT ANY WARRANTY, without even the implied warranty of MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.

Please refer to the detailed terms and conditions thereof shown in the device settings menu.

At least three (3) years from delivery of this product, Panasonic will give to any third party
who contacts us at the contact information provided below, for a charge no more than our
cost of physically performing source code distribution, a complete machine-readable copy of
the corresponding source code covered under GPL V2.0, LGPL V2.1 or the other licenses
with the obligation to do so, as well as the respective copyright notice thereof.

Contact information: plc.peweu@eu.panasonic.com
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Important symbols

Important symbols

One or more of the following symbols may be used in this documentation.

The following symbols are used to indicate the type of hazard.

Indicates a hazardous situation which, if not avoided, will result in death or serious injury.

Indicates a hazardous situation which, if not avoided, could result in death or serious injury.

Indicates a hazardous situation which, if not avoided, could result in minor or moderate
injury.

Indicates a property damage message.
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 Safety precautions

Safety precautions

Observe the following notices to ensure personal safety or to prevent accidents. To ensure
that you use this product correctly, read this User’s Manual thoroughly before use. Make
sure that you fully understand the product and information on safety.

• Always take precautions to ensure the overall safety of your system, so that the whole
system remains safe in the event of failure of this product or other external factor.

• Do not use this product in areas with inflammable gas. It could lead to an explosion.

• Exposing this product to excessive heat or open flames could cause damage to electronic
parts.

• To prevent abnormal exothermic heat or smoke generation, do not use this product
continuously at the maximum performance values listed in the specifications.

• Do not disassemble or modify the product. It could lead to abnormal exothermic heat or
smoke generation.

• Do not touch the terminals while the electricity is turned on. It could lead to an electric
shock.

• Use external devices to ensure safety related functions such as the emergency stop and
interlock circuit.

• Connect the wires and connectors securely. A loose connection might pose an electrical
hazard, which could result in a short-circuit, exothermic heat or smoke generation.

• Do not allow foreign matter such as liquid, flammable materials, metals to enter the
product. It could cause excessive exothermic heat or smoke generation.

• Do not undertake construction (such as connection and disconnection) while the power
supply is on. It could lead to an electric shock.
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Network security

Network security

Implementing measures to protect your network is crucial to keep your network and its traffic
secured.

As you will use this product connected to a network, your attention is called to the following
security risks.

• Leakage or theft of information through this product

• Use of this product for illegal operations by persons with malicious intent

• Interference with or stoppage of this unit by persons with malicious intent

It is your responsibility to take precautions such as those described below to protect yourself
against the above network security risks.

• Use this product in a secure network by using protection tools such as a firewall.

• If this product is connected to a network that includes PCs, make sure that the system
is not infected by computer viruses or other malicious entities (using a regularly updated
antivirus program, anti-spyware program, etc.).

• Use this product in an environment that has LAN, VPN (virtual private network) or leased
line network.

• Use this product in an environment where only limited people concerned can enter.

• Use this product and connected devices such as a PC and tablet securing safety.

• Do not install this product in locations where the product or the cables can be destroyed
or damaged by persons with malicious intent.

Note that incorrect setting of the connection to the existing LAN might cause malfunction in
the devices on the network. Consult your network administrator before connecting.
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1 Product overview

1 Product overview

1.1 Product package

The FP‑I4C product package contains the following items.

• 1 x FP-Industry 4.0 Communicator (FP‑I4C unit)
Product number: AFP4C

• 1 x 24V DC power supply cable
Product number: AFPG805

• 1 x leaflet providing installation instructions

• 1 x 16-pin spring force plug (Phoenix Contact Co. MC0.5/8-ST-2,54)

1.2 System requirements

To configure your applications and to access FP series PLCs via Ethernet, you only need a
standard browser. For HMWIN Studio, your PC must meet some basic requirements.

Supported browsers:

• Microsoft Edge

• Mozilla Firefox

• Google Chrome

• Safari

• Opera

HMWIN Studio has the following system requirements:

• Microsoft Windows® 7, Windows® 8.x or Windows® 10

• Hard disk with at least 500MB free disk space, 512MB RAM, Ethernet connection

HMWIN Studio can be downloaded free of charge from the Panasonic Download Center .

10  FP-I4C Unit

https://industry.panasonic.eu/downloads


 1 Product overview

1.3 Features

The FP‑I4C unit connects PLCs and other devices securely with databases, cloud servers,
and remote control systems.

The unit works as an interface between a LAN or WAN (Internet/Intranet) and all PLCs of the
FP series. It comes in a compact housing with multiple interfaces and offers various services
for data exchange.

Interfaces:

• RS232C interface

• Switchable RS232C/RS485 interface

• 2 Ethernet interfaces

• 2 USB 2.0 host ports

• 2 digital function inputs

• Redirection from Ethernet to any other interface

Modbus TCP/RTU support:

• Modbus RTU master functionality

• Modbus TCP client/server functionality

• Modbus TCP gateway

Other features:

• Configuration via Web interface in any standard browser

• Secure data transmission and authentication

• Web server

• Data logger

• FTP client

• SMTP/POP3 (email) client

• MQTT protocol

• HTTP client

• SQL client

• Script function

• REST API

• IEC60870 protocol
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1 Product overview

1.4 Part names

The FP‑I4C unit is equipped with multiple communication interfaces, status LEDs, function
inputs, a reset tact switch, and an expansion connector.

(1)

(9)

(8)

(4)

(5)

(6)

(7)

(10)

(3) (2)

(1) Reset tact switch
(2) Status LEDs
(3) ETH0, ETH1, Ethernet connectors
(4) USB1, USB 2.0 host port (500mA)
(5) USB2, USB 2.0 host port (100mA)
(6) COM1 RS232 (non-insulated)
(7) F1, F2, function inputs (pull-up design)
(8) COM2 RS232/RS485 (insulated, switchable)
(9) 24V DC power supply connector
(10) Expansion connector for FP0/FP0R expansion units (16 pins)

Related topics

Reset tact switch (page 14)

Wire the power supply (page 25)

Status LEDs (page 13)
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 1 Product overview

1.5 Status LEDs

The LEDs on the FP‑I4C unit display the operation and communication status.

ET
H

1
ET

H
0

(6)

(2)
(3)

(5)

(4)

(1)

(7)

(1) PWR
(2) CON
(3) USR
(4) MEM
(5) USB 1, USB 2
(6) TX1
(7) TX2

LED Color LED status Description

PWR Green On Power supply is on and self-test is
completed.

CON Yellow User-defined User-defined, controlled by script function

User-defined User-defined, controlled by script functionUSR Yellow

Flashes
(heartbeat 1/s)

A system reset initiated by the reset tact
switch is active.

MEM Orange On Data is written to the USB flash drive.

USB 1 Green On A device is connected to USB port 1.

USB 2 Green On A device is connected to USB port 2.

TX1 Green Flashes
(rate depending on data
traffic)

Communication via COM1 RS232 is
active.

TX2 Green Flashes
(rate depending on data
traffic)

Communication via COM2 RS232/RS485
is active.

Related topics

Reset tact switch (page 14)
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1 Product overview

1.6 Reset tact switch

A small tact switch within the housing on the top side can be used to restart or to reset the
FP‑I4C unit.

To restart or to reset the unit to the factory settings, use a paperclip or similar and press the
tact switch 3 times within 3s. The yellow USR LED starts flashing (heartbeat 1/s).

• To restart the unit, press the tact switch again for 3 to 6s.

• To reset the unit, press the tact switch for at least 6s after the LED began to flash. The
unit will be restarted and all user data are removed.

1.7 Devices supported by USB host ports

The USB host ports support the FP series PLCs and GT series HMIs listed in the following
targeted peripheral list.

Commercial USB flash drives and hard disks (max. 500mA on upper USB connector) can
also be connected.

• Panasonic GT USB driver ver. 1.0
Model: GT series, manufacturer: Panasonic Electric Works, Ltd.,
vendor ID: 0x0986, product ID: 0x0310

• Panasonic FP series USB driver
Model: PLC FP0H, FP7, FP0R, manufacturer: Panasonic Electric Works, Ltd.,
vendor ID: 0x0986, product ID: 0x0320

• Panasonic Eco-POWER METER
Model: Eco-POWER METER, manufacturer: Panasonic Electric Works, Ltd.,
vendor ID: 0x04da, product ID: 0x4201

• Panasonic FP-X series USB driver
Model: CP210x UART Bridge, e.g. FP-X, manufacturer: Cygnal Integrated Products,
vendor ID: 0x10C4, product ID: 0xEA60
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 1 Product overview

1.8 Specifications

The FP‑I4C unit has the following characteristics and technical specifications.

Item Description

Product number AFP4C

Rated input voltage 24V DC, use the power supply cable (AFPG805) supplied with the unit

Operating voltage range 21.6–26.4V DC, supplied by class 2 circuit only

Serial interfaces COM1 RS232 (non-insulated), COM2 RS232/RS485 (insulated,
switchable)
16-pin spring force plug by Phoenix Contact Co. (MC0.5/8-ST-2,54)

Ethernet 2 Ethernet connectors, 10BASE-T/100BASE-TX auto-negotiation via
RJ45 female connector

USB 2 USB connectors, USB 2.0 full speed, max. 500mA (USB1), max.
100mA (USB2)

Function inputs 2 binary inputs (pull-up design) for optional functions

Operation status LEDs 7

Protocols and standards TCP/IP, UDP/IP, DHCP, FTP, FTPS, SSH, HTTP, HTTPS, SMTP,
ESMTP-Auth, POP3, NTP, Modbus, DNS, SNMP, VPN, VNC, MQTT,
SQL, OPC UA

Flash memory 2.4GB user/configuration data

RAM 496MB

Current consumption ≈75mA at 24V DC (without expansion unit, USB flash memory, etc.)

Degree of protection IP20

Operating temperature 0°C to +55°C

Storage temperature -20°C to +70°C

Operating humidity 10%–95% RH (at 25°C, non-condensing)

Storage humidity 10%–95% RH (at 25°C, non-condensing)

Vibration resistance 10Hz to 55Hz, 1 cycle per minute with a double amplitude of 0.75mm;
10min on 3 axes

Shock resistance ≥10g, 4 times on 3 axes

Unit dimensions Height: 90mm, width: 25mm, depth: 64mm

Weight ≈110g

Operation conditions Free from corrosive gases and excessive dust

Conformity to EU
directives and standards

2011/65/EU RoHS, 2014/30/EU EMC, EN IEC 63000:2018, EN
61326-1:2013

UL approval UL number "2LD7" (file E232530)
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1 Product overview

1.9 Dimensions

The dimensions of the FP‑I4C unit are indicated in the technical drawings.

FP
-I4

C

R
S2

32
R

S2
32

/R
S4

85
US

B1
US

B2
ET

H
1

ET
H

0

S R
G1
F1 F2

S/- R/+
S/- R/+

S/- E
G2 G2

G1

60.0 3.5

90.0

25.0

[mm]

 

60.011.5 3.5

90.0

[mm]

Right side view of the unit with the 16-pin connector installed
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 2 Installation

2 Installation

2.1 Installation environment

To prevent failure or malfunctions, the installation environment must comply with the
specifications of the FP‑I4C unit.

After installing the unit, make sure to use it within the range of the general specifications:

• Operating temperature: 0°C to +55°C

• Operating humidity: 30% to 85% RH (at 25°C, non-condensing)

• Pollution degree: 2

• Do not use the unit in the following environments:
‒ Direct sunlight

‒ Sudden temperature changes causing condensation

‒ Flammable or corrosive gases

‒ Excessive airborne dust, metal particles or salts

‒ Benzine, paint thinner, alcohol or other organic solvents, or strong alkaline solutions
such as ammonia or caustic soda

‒ Vibration, shock, or direct drop of water

• Avoid noise interference from the following items:
‒ Influence from power transmission lines, high voltage equipment, power cables,

power equipment, radio transmitters, or any other equipment that would generate
high switching surges. Maintain at least 100mm of space between these devices and
the unit.

‒ If noise occurs in the power supply line even after the above countermeasures are
taken, it is recommended to supply power through an isolated transformer, noise
filter, or the like.

• Take measures regarding heat discharge:
‒ Always install the unit orientated with the Ethernet ports facing outward on the top in

order to prevent the generation of heat.

FP
-I4

C

R
S2

32
R

S2
32

/R
S4

85
US

B1
US

B2
ET

H
1

ET
H

0

S R
G1
F1 F2

S/- R/+
S/- R/+

S/- E
G2 G2

G1

COM1

COM2

PWR

CON

2

USR

MEM

1

TX2

TX1

FP-I4C

R
S232

R
S232/R

S485
USB1

USB2
ETH

1
ETH

0

SR
G1
F1F2

S/-R/+
S/-R/+

S/-E
G2G2

G1

COM1

COM2

PWR

CON

2

USR

MEM

1

TX2

TX1

‒ Do not install the unit above devices which generate heat, such as heaters,
transformers or large-scale resistors.
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2 Installation

2.2 Installation space

Make sure to keep a minimum distance to other devices to avoid effects from noise or heat
and to permit unit replacement.

• Leave at least 50mm of space between the wiring ducts of the unit and other devices to
allow heat radiation and unit replacement.

(1)

(1)

FP-I4C

(1) 50mm or more

• Maintain a minimum of 100mm between devices to avoid adverse effects from noise and
heat when installing a device or panel door to the front of the unit.

(2)

(1)

FP-I4C

(1) 100mm or more
(2) Other device or panel door

• Keep the first 100mm from the front surface of the unit open in order to allow room for
wiring.

2.3 Attach the unit to a DIN rail

The unit is designed for easy installation on DIN rails.

1. Fit the upper hook of the unit onto the DIN rail.
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 2 Installation

2. Without moving the upper hook, press on the lower hook to fit the unit into position.

1

2 (2)

(1)

(1) Mounting panel
(2) DIN rail

2.4 Remove the unit from a DIN rail

You can easily remove the unit from a DIN rail with a slotted screwdriver.

1. Insert a slotted screwdriver into the DIN rail attachment lever.

2. Pull the attachment lever downwards.

3. Lift the unit and remove it from the rail.

3

2
1

(2)

(1)

(1) DIN rail
(2) DIN rail attachment lever

2.5 Install the unit on a slim mounting plate (AFP0803)

To attach the unit directly to the wall, you can use a slim type mounting plate, which can be
ordered separately.

Use M4 size pan-head screws to attach the mounting plate to the mounting panel.
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2 Installation

(3)
(2)

(1)

[mm]6.0

60.0

(1) FP0 slim type mounting plate AFP0803
(2) Screw
(3) Mounting panel

1. Fit the upper hook of the unit onto the mounting plate.

2. Without moving the upper hook, press on the lower hook to fit the unit into position.

2

1

2.6 Install the unit on a flat mounting plate (AFP0804)

To attach the unit sideways, you can use a flat type mounting plate, which can be ordered
separately.

Use M4 size pan-head screws to attach the mounting plate to the mounting panel.

AFP0804

[mm]

(3)

(2)

(1)

60.0

(1) FP0 flat type mounting plate AFP0804
(2) Screw
(3) Mounting panel

1. Raise the expansion hooks on the top and bottom of the unit.

2. Install the unit on the mounting plate.

20  FP-I4C Unit



 2 Installation

3. Align the expansion hooks with the plate and press the hooks back down.

FP
-I4

C

R
S2

32
R

S2
32

/R
S4

85
US
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B2
ET

H
1

ET
H

0

S R
G1
F1 F2

S/- R/+
S/- R/+

S/- E
G2 G2

G1

2

1

3

3

1

Note

A unit with an attached flat type mounting plate can also be installed sideways on a DIN
rail.

FP
-I4

C

R
S2

32
R

S2
32

/R
S4

85
US

B1
US

B2
ET

H
1

ET
H

0

S R
G1
F1 F2

S/- R/+

S/- R/+

S/- E
G2 G2

G1

2

1

(2)

(1)

(1) DIN rail
(2) FP0 flat type mounting plate AFP0804

2.7 Add FP0/FP0R expansion units to the FP‑I4C unit

The FP0/FP0R expansion units are connected on the right side of the FP‑I4C unit.

1. Raise the expansion hooks on the top and bottom sides of the FP‑I4C unit with a
screwdriver.
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2 Installation

2. Align the pins and holes in the four corners of the units and press the two units together.

(1)

(2)

(1) FP‑I4C unit
(2) FP0/FP0R expansion unit

3. Press down the expansion hooks raised in step 1 to secure the unit.
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 3 Wiring

3 Wiring

3.1 Connection to PLC TOOL port using cable AIGT8192

Use the cable AIGT8192 to connect the FP‑I4C unit to the 5-pin mini DIN male TOOL port of
an FP0R, FPƩ, FP-X, or FP2SH type PLC.

Use either COM1 or COM2 depending on your setting for “Service control interface” in the
FP‑I4C Web interface.

The cable AIGT8192 can be ordered as an accessory. Remove the ferrules of the cable
before inserting the wires into the connector.

Using COM1:

1
2

3 5

4

R (COM1)
G1 (COM1)

S/- (COM2)

F1

S (COM1)
G1 (COM1)

S/- (COM2)
S/- (COM2)

F2

R/+ (COM2)
R/+ (COM2)
E
G2 (COM2)G2 (COM2)

AIGT8192, 5-pin mini DIN male (left) and FP‑I4C unit, 16-pin connector (right)

Using COM2:

1

2

3 5

4

R (COM1)
G1 (COM1)

S/- (COM2)

F1

S (COM1)
G1 (COM1)

S/- (COM2)
S/- (COM2)

F2

R/+ (COM2)
R/+ (COM2)
E
G2 (COM2)G2 (COM2)

FP‑I4C unit, 16-pin connector (left) and AIGT8192, 5-pin mini DIN male (right)
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3 Wiring

3.2 Connection to PLC COM port

Wire the 16-pin connector of the FP‑I4C unit directly to the COM port of an FP0R, FP-X,
FPƩ, FP0H, or FP7 type PLC.

Use either COM1 or COM2 depending on your setting for “Service control interface” in the
FP‑I4C Web interface.

Suitable wire: AWG26-24

Using COM1:

R (COM1)
G1 (COM1)

S/- (COM2)

F1

S (COM1)
G1 (COM1)

S/- (COM2)
S/- (COM2)

F2

R/+ (COM2)
R/+ (COM2)
E
G2 (COM2)G2 (COM2)

S 
   

  R
   

   
G

PLC COM port, 3-pin screw terminal (left) and FP‑I4C unit, 16-pin connector (right)

Using COM2:

R (COM1)
G1 (COM1)

S/- (COM2)

F1

S (COM1)
G1 (COM1)

S/- (COM2)
S/- (COM2)

F2

R/+ (COM2)
R/+ (COM2)
E
G2 (COM2)G2 (COM2)

S 
   

  R
   

   
G

PLC COM port, 3-pin screw terminal (left) and FP‑I4C unit, 16-pin connector (right)

3.3 RS485 connection to Eco-POWER METER

Use COM2 RS485 to connect the FP‑I4C unit to an Eco-POWER METER.

Suitable wire: AWG26-24
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 3 Wiring

F2

R (COM1)
G1 (COM1)

S/- (COM2)

F1

S (COM1)
G1 (COM1)

S/- (COM2)
S/- (COM2)

R/+ (COM2)
R/+ (COM2)
E
G2 (COM2)G2 (COM2)

1
+

2
+

3
-

4
-

5
END

6
END

FP‑I4C unit, 16-pin connector (left) and Eco-POWER METER terminal block (right)

3.4 Wire the power supply

Use the power supply cable (AFPG805) that comes with the unit to connect the power
supply.

(5)

(3)

(4)

(2)

(1)

(1) Power supply connector
(2) Power supply cable (AFPG805)
(3) Brown: 24V DC
(4) Blue: 0V
(5) Green: must be connected to frame ground

The FP‑I4C unit will turn on as soon as the power supply has been connected. The green
LED PWR will turn on after self-test.

When connecting the power supply (class 2 circuit), make sure the polarity (+/-) is correct.

If you connect an FP0/FP0R expansion unit, both units must be supplied by the same power
supply.
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3.5 Pre-startup checklist

Check the following items prior to applying power to the system.

Perform the pre-startup checks with the power turned off.

1. Is the unit securely fixed to the control panel?

2. Are all wires firmly secured to the terminals?

3. Are the connectors properly wired with respect to voltage and polarity?

4. Is the green wire connected to frame ground?
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4 Getting started

4.1 Basic communication processes

The FP‑I4C unit is equipped with multiple interfaces and supports a variety of protocols and
services.

All services (FTPC, MQTT, data logger, etc.) use a so-called service control interface to poll
the control and status flags/registers of connected devices. This service control interface is
configured using the FP‑I4C unit's Web interface.

Via TCP listening ports and port redirections, all interfaces are also available to external
clients, such as Control FPWIN Pro7 or SCADA systems. Port redirections can be configured
in the Web interface.

“INTERN” refers to the addressable internal memory areas of the FP‑I4C unit which is
accessible via Modbus/TCP or the script function. If the unit is used as a stand-alone FTP or
SMTP client (no PLC connected), select “INTERN” as service control interface.

The data logger can collect data from all interfaces, allowing you to connect multiple
sensors. The log function can be controlled by time trigger or by PLC via the service control
interface.

INTERN

ETHERNET (COM4)

RS232/RS485 (COM2)

RS232 (COM1)

USB (COM3)
Service control 

interface
Measurement 

and other 
devices

Logging 
control

Data logger
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Related topics

Port redirection (page 31)

Configure a port redirection (page 32)

4.2 Getting connected to the FP‑I4C unit

The FP‑I4C unit is configured using any standard Web browser.

To perform an initial function test and to configure the FP‑I4C unit, connect a PC and the unit
in the same Ethernet network and connect the 24V DC power supply.

You can connect the unit and the PC directly via LAN cable. In this case, use the ETH1
connector, which has a fixed IP address, and set the IP address in your PC (see "Related
topics").

In larger networks where IP addresses area usually assigned by a DHCP server, you first
need to find out the IP address of your FP‑I4C unit. This can easily be done with the HMWIN
Studio software. Use the ETH0 connector in networks with a DHCP server.

With the IP address of your device and the proper URL, you can open the FP‑I4C Web
interface in your browser. You can now activate and configure the required services and
functions.

The Web interface is divided in application settings and system settings. Use the
corresponding menu commands to switch between these areas. Or enter the URL to access
each area directly:

• “Application Settings”: https://[IP address]/fp_config

• “System Settings”: https://[IP address]/machine_config

Replace [IP address] with the IP address of your FP‑I4C unit (e.g.
https://192.168.0.10/machine_config).

In the “System Settings”, you can change the user interface language and password (see
"Related topics").

You can find detailed operating instructions for the FP‑I4C Web interface if you click on the
help button in the status bar of the “Application Settings”.

Related topics

Connect the FP‑I4C unit directly to a PC (page 29)

Connect the FP‑I4C unit to a PC via DHCP server (page 30)

Change the user interface language (page 33)

Change passwords (page 34)
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4.3 Connect the FP‑I4C unit directly to a PC

For a direct connection, use a standard LAN cable and the unit's ETH1 connector.

The factory default IP address of the ETH1 connector is 192.168.0.1. This address is printed
on a label attached to the unit's housing. The PC must be on the same subnet as the FP‑I4C
unit.

1. Connect a LAN cable between your PC and the ETH1 connector.
A B

FP-I4CFP-I4C

A: Direct connection, B: Connection using a network switch

2. Set the IP address in your PC.
In Windows, go to “Network Connections” > “Change adapter options”. Select
“Ethernet” > “Properties”. On the “Network” tab, select “Internet protocol, Version
4 (TCP/IPv4)” > “Properties”. Select “Use the following IP address” and set the IP
address.
Example:

IP address: 192.168.0.10
Subnet mask: 255.255.255.0
(Settings for default gateway and preferred DNS server not required.)

3. Open your browser and enter the URL https://192.168.0.1/machine_config.
Depending on your browser, an insecure connection warning may be displayed. Follow
the instructions in your browser to accept the connection. You will then be forwarded to
the Web interface of the FP‑I4C unit.

4. Log in with the user name "admin" and the default password "admin".
You are now in the system settings area where you can make general network and
service settings, change the user interface language and password (see "Related
topics"). We recommend that you change the default password as soon as possible.

5. Select “Application Settings” to go to the application settings area.

You are now ready to configure the services required for your application.

Related topics

Change the user interface language (page 33)

Change passwords (page 34)
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4.4 Connect the FP‑I4C unit to a PC via DHCP server

If you connect the FP‑I4C unit and the PC in an Ethernet network with a DHCP server, you
need to know which IP address was assigned to the unit.

You can easily find out the IP address of your unit with the HMWIN Studio software. The
software is available free of charge in our Panasonic Download Center .

1. Connect a LAN cable between the ETH0 connector of the FP‑I4C unit and your Ethernet
network.
For Ethernet connections using a DHCP server it is important that you use the top
Ethernet connector ETH0.

FP-I4C

2. Start HMWIN Studio to find out the IP address of the FP‑I4C unit.

3. Go to “Run” > “Manage Target” and select the “Board” tab.
In the device list of your DHCP network you can find the IP address of theFP‑I4C unit. If
there are multiple devices in the list, compare the MAC address to the MAC address of
the ETH0 connector to find the right device. The MAC address is printed on a label that
can be found on the unit's housing.

4. Open your browser and enter the URL https://[IP address]/machine_config.
Replace [IP address] with the IP address of your FP‑I4C unit (e.g.
https://192.168.0.10/machine_config).
Depending on your browser, an insecure connection warning may be displayed. Follow
the instructions in your browser to accept the connection. You will then be forwarded to
the Web interface of the FP‑I4C unit.

5. Log in with the user name "admin" and the default password "admin".
You are now in the system settings area where you can make general network and
service settings, change the user interface language and password (see "Related
topics"). We recommend that you change the default password as soon as possible.
We also recommend setting a static IP address:
a. Select “Network” > “Network Interface”.

b. Select “EDIT” and then “DHCP disabled” for “eth0” so that DHCP is disabled for
both Ethernet connectors.
Make settings for “Address” (e.g. 192.168.100.10), “Netmask” (e.g. 255.255.255.0),
and “Gateway” (e.g. 192.168.100.1).

6. Select “Application Settings” to go to the application settings area.

You are now ready to configure the services required for your application.
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Related topics

Change the user interface language (page 33)

Change passwords (page 34)

4.5 Port redirection

For some applications, port redirections need to be configured to forward data packages
from the TCP listening port to another FP‑I4C interface.

General principle

An open TCP listening port is redirected to a serial COM interface (blue arrows). This allows
external clients to communicate via TCP with a device connected to the COM interface.

192.168.178.100

COM1 (RS232)
192.168.178.20

TOOL/
COM

FP-I4C FP0R
9094

External client TCP listening 
port COM interface PLC

Example

Three TCP listening ports are opened on the FP‑I4C unit (9094, 502, and 9095) and
redirected to two serial COM interfaces connected to an FP0H PLC:

• Port 9094 handles requests from the PLC programming software Control FPWIN Pro7 to
the PLC. The port is redirected to the USB interface.

• Port 502 is used as a Modbus TCP gateway to handle data requests from a Modbus TCP
client.

• Port 9095 is used as a MEWTOCOL server to handle MEWTOCOL data requests from a
SCADA system.
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Control FPWIN Pro7 9094 USB

502

9095

RS232/RS485 FP0H

HMI Runtime

127.0.0.1 (localhost)

FP-I4C
e.g. 192.168.178.173

External client TCP listening 
port COM interface PLC

Modbus TCP client

SCADA system

In addition, a Web server (HMI Runtime) is installed in the FP‑I4C unit to show PLC data
on an HTML page. The Web server connects to the PLC using the localhost IP address
127.0.0.1. In the example, HMI Runtime collects data from the PLC via MEWTOCOL and
port 9095.

The data from port 502 and 9095 is redirected to the RS485/RS232 interface and then
transmitted to the PLC FP0H. The SCADA system with polling rates in the millisecond range
causes high loads on the serial interface. It is therefore advisable to use a different serial
interface (in this example USB) for remote programming of the PLC.

Related topics

Configure a port redirection (page 32)

4.6 Configure a port redirection

With the PLC connection wizard, you can set a port redirection very quickly. Alternatively,
you can also configure the redirection manually.

In the following example, the TOOL or COM port of the FP0R PLC is connected to COM1
RS232 of the FP‑I4C unit. A PC is connected to one of the Ethernet interfaces of the unit. To
establish a connection between the PC and the PLC via the FP‑I4C unit, open port 9094 for
COM1 RS232, and make the communication settings.
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192.168.178.100

COM1 (RS232)

192.168.178.20

TOOL/
COM

FP-I4C FP0R

9094

Using the wizard

1. Go to “COM Interface” and select “Start wizard” to start the PLC connection wizard.

2. Select “Simple mode” and “Continue”.

3. Select the interface used to communicate with the PLC (“COM1 RS232”) and then
“Continue”.

4. Set baud rate and parity (or IP address and port if the interface is COM4 Ethernet).

5. Enter the TCP listening port number (9094).

6. Select “Finish” and save your configuration.

Manual configuration

1. Go to “COM Interface” and enable the interface “COM1 RS232” to communicate with the
PLC.

2. Make the desired communication settings.

3. Go to “Service control interface” and select “RS232” as “COM interface to control device
(PLC)” and the station number.

4. Go to “Port” > “Ports and restrictions” and select “Add new”.

5. Specify the TCP listening port number 9094 and the COM interface “RS232” to which
the data packets should be forwarded, and make all other desired communication
settings.

6. Save your configuration.

4.7 Change the user interface language

The language of the user interface can be changed in the system settings.

Go to “System Settings” > “Language” and select the desired language.

Note that the application settings and the online help are not yet available in all of the
languages.

FP-I4C Unit  33



4 Getting started

4.8 Change passwords

For security reasons, we recommend that you change the default passwords in the FP‑I4C
Web interface.

You can set different passwords for the administrator and standard users. There are certain
access restrictions for standard users.

If you forget your password, you must reset the FP‑I4C unit to the default settings with the
reset tact switch.

The following default passwords have been set:

Service User name Password

Configuration/SSH (if enabled) admin admin

SSH (if enabled) standard user user user

FTP server (if enabled) for logged data log log

1. Go to “System Settings” > “Authentication”.

2. Select “EDIT” to change the passwords.
Allowed characters for passwords: all letters, numbers and special characters (e.g. #!$).
Spaces are not allowed.

Related topics

Reset tact switch (page 14)

User rights (page 34)

4.9 User rights

Access to certain functions and settings is restricted to administrators. The functions
accessible to users have a check mark.

System settings

Function Admin User

Change language ✓ ✓

View system status ✓ ✓

Save log file ✓ ✓

Change date and time ✓ ✓

Change network settings ✓ ✓
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Function Admin User

View data, settings, and main OS partitions ✓ ✓

Change, clear, and update partitions ✓ ✕

Restart system ✓ ✓

Change user password ✓ ✓

Change admin password ✓ ✕

Application settings

Function Admin User

Change COM settings ✓ ✕

Change port settings ✓ ✕

PLC connection test ✓ ✓

Start PLC connection wizard ✓ ✕

Change data logging settings ✓ ✕

Download log files ✓ ✓

Delete log files ✓ ✕

Change MQTT settings ✓ ✕

Save or download MQTT library or example ✓ ✓

Change date and time settings ✓ ✕

Change FTP client settings ✓ ✕

Save or download FTP library or example ✓ ✓

Change script settings ✓ ✕

Change SQL client settings ✓ ✕

Save or download SQL library or example ✓ ✓

Change email client settings ✓ ✕

Save or download email library or example ✓ ✓

Change HTTP client settings ✓ ✕

Save or download HTTP library or example ✓ ✓

Change REST API settings ✓ ✕

Change IEC60870 settings ✓ ✕

Save configuration changes ✓ ✕

Reset configuration to default ✓ ✕

Backup application settings ✓ ✓

Restore application settings ✓ ✕
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Related topics

Change passwords (page 34)
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5 Example: Data logging from different devices

5.1 Functional overview

During data logging, the FP‑I4C unit collects and saves the data from all connected devices.
The log files can then be downloaded or transmitted to a server.

This sample application is the basic configuration of a PLC-based monitoring and control
system that collects and evaluates process data. In the figure, an FP0R PLC and four power
meters of the Panasonic Eco-POWER METER series are connected to the FP‑I4C unit.
The measurement values from temperature sensors connected to the PLC will be logged in
the FP‑I4C unit. The energy consumption values supplied by the power meters will also be
logged and can be transmitted to the PLC using the script function. Logging is performed at
a fixed time interval set in the FP‑I4C unit.

FP-I4C FP0R

KW9M
KW2M

KW2M-A

Eco-POWER METER

KW2M-A

Eco-POWER METER

Configuration

• The FP‑I4C unit has the fixed IP address 192.168.0.1. It is connected to the Ethernet
devices via a network switch. The PC must be on the same subnet as the FP‑I4C unit.

• The KW2M power meters have the IP addresses 192.168.0.70 and 192.168.0.71.

• The KW9M power meters have the station numbers 1 and 2 and are connected via
RS485 (19200 baud, odd parity, MEWTOCOL-COM protocol).

• The FP0R PLC is connected to the FP‑I4C unit with its TOOL port (115200 baud, odd
parity, MEWTOCOL-COM protocol).
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Step-by-step instructions

1 Connect the FP0R PLC to the FP‑I4C unit (page 38)
Connect the FP0R and FP‑I4C units and make the TOOL port settings for the PLC.

2 Connect the power meters (page 39)
Connect two KW2M power meters via Ethernet and two KW9M power meters via
RS485.

3 Connect the FP‑I4C unit to the network (page 40)
Make the physical network connection, set a static IP address, enable the router
function, and configure the RS232 COM1 interface to the FP0R PLC.

4 Configure data logging (page 41)
Make the settings to log the temperature data and the measured energy
consumption.

5 Import variables from CSV files (page 44)
Instead of adding single data points, you can import CSV files.

6 List and download log files (page 45)
Use this function to generate a list of all log files and to download individual log files.

5.2 Connect the FP0R PLC to the FP‑I4C unit

Connect the FP0R and FP‑I4C units and make the TOOL port settings for the PLC.

FP-I4C FP0R

USB Control
FPWIN Pro7

RS232

1. Connect the TOOL port of the FP0R PLC to the COM1 RS232 interface of the FP‑I4C
unit, e.g. using cable AIGT8192 (see "Related topics").

2. Connect your PC to the PLC, e.g. with a USB cable, and turn on the power of the PLC.

3. Start the Control FPWIN Pro7 programming software to configure the TOOL port of the
PLC.

4. Open or create a Control FPWIN Pro7 project and make sure the set PLC type is an
FP0R PLC.

5. Go to “System registers” > “Serial ports” > “TOOL”.
Make the following settings:
Communication mode: “MEWTOCOL-COM slave”, “Station number”: “1”, “Baud rate”:
“115200”, “Data length”: “8 bits”, “Parity”: “Odd”, “Stop bits”: “1 bit”

6. When you have completed your settings, transfer the configuration to the PLC.
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For details on wiring and configuring the FP0R PLC, refer to the PLC's documentation.

Related topics

Connection to PLC TOOL port using cable AIGT8192 (page 23)

5.3 Connect the power meters

Connect two KW2M power meters via Ethernet and two KW9M power meters via RS485.

FP-I4C

KW9M
KW2M

KW2M-A

Eco-POWER METER

KW2M-A

Eco-POWER METER

1. Use a LAN cable to connect the KW2M power meters to the network switch.

2. Connect the KW9M power meters to the RS485 interface in a daisy chain:

F2

R (COM1)
G1 (COM1)

S/- (COM2)

F1

S (COM1)
G1 (COM1)

S/- (COM2)
S/- (COM2)

R/+ (COM2)
R/+ (COM2)
E
G2 (COM2)G2 (COM2)

A
+

B
-

A
+

B
-

Suitable wire: AWG26-24
We recommend that you install a terminating resistor on both ends of the RS485
connection. On the FP‑I4C side, place a 100Ω resistor between E and R/+. On the
second KW9M power meter, place a 120Ω resistor between A+ and B-.

3. Make the power meter settings:
KW2M:
Set the IP address to 192.168.0.70 and 192.168.0.71 and the subnet mask to
255.255.255.0.
KW9M:
Protocol: MEWTOCOL, baud rate: 19200, parity: Odd (8b - o), station numbers: 1 and 2
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5.4 Connect the FP‑I4C unit to the network

Use a standard browser to make the communication settings for the FP-I4C unit.

This task includes the following steps:

1 Make the physical connection

2 Configure the FP‑I4C unit's RS232 COM1 interface to the FP0R PLC

3 Enable COM2 RS485/RS232 for communication with the KW9M power meters

4 Enable COM4 ETHERNET for communication with the KW2M power meters

Make the physical connection

Connect your PC to the FP‑I4C unit and set the IP address of the PC, e.g. 192.168.0.10 (see
"Related topics"). The PC must be on the same subnet as the FP‑I4C unit.

Because we are using static IP addresses, connect the LAN cable to the ETH1 connector of
the FP‑I4C unit.

Configure the RS232 COM1 interface to the FP0R PLC

1. Open your browser and enter the URL https://192.168.0.1/fp_config.
Depending on your browser, an insecure connection warning may be displayed. Follow
the instructions in your browser to accept the connection. You will then be forwarded to
the Web interface of the FP‑I4C unit.

2. Go to “COM Interface” > “COM settings - FP‑I4C” and enable “COM1 RS232”.
Keep the default settings (“Protocol”: “MEWTOCOL”, “Autobaud”: Enabled, “Baud rate”:
“115200”, “Parity”: “Odd”, “Timeout”: “2000”).

Enable COM2 RS485/RS232

1. Enable “COM2 RS485/RS232”.

40  FP-I4C Unit



 5 Example: Data logging from different devices

2. Make the following settings (keep the default settings for all other parameters):
“Protocol”: “MEWTOCOL”
“Autobaud”: Disabled (only PLCs can respond to status requests)
“Baud rate”: “19200”

Enable COM4 ETHERNET

1. Enable “COM4 ETHERNET”.

2. Make the following settings:
“Protocol”: “MODBUS”
“Timeout”: “2000”
“IP address”: “192.168.0.0”
“Port”: “502”
“Address offset”: Enabled and set to 0

3. Save your configuration.

Related topics

Connect the FP‑I4C unit directly to a PC (page 29)

5.5 Configure data logging

Make the settings to log the temperature data and the measured energy consumption.

A log file must be configured for each device.

In this example, the two power meters log the total energy consumption. Please refer to the
power meter documentation for details on register addresses and data format.

This task includes the following steps:

1 Make general log settings
This includes the data storage location and CSV file settings. If you add more than
one log file, you need to make the general log settings only once.

2 Configure the log files and data points for each device
Specify the COM interface to receive the log data, the station number of the
connected device, the trigger that starts data logging, and the data points (in this
example temperature and energy consumption values).
If you need to configure many data points, we recommend importing the variables
from a CSV file.

Make general log settings

Go to “Data Logger” > “General log settings” and turn on “Use data logger”.
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Make the following settings:

“Data storage location”: “Internal memory”
“Show advanced settings”: Enabled
“Enable PLC memory area, start address”: Disabled

Keep the default settings for all other parameters.

Configure data logging for the FP0R PLC

1. Go to “Log file settings”, select “Add new”, and open the new configuration.
Make the following settings (keep the default settings for all other parameters):
“File name”: FP0R_RS232
“COM interface/station number”: RS232, 0
“Trigger cycle time”: 300 (a new value is logged every 5min)

2. Go to “Data point settings”, select “Add new”, and select the new data point from the list.
Make the following settings:
“Data point name”: Temperature
“Unit”: C
“COM interface”: RS232, “Station number”: 0
“Register type”: “Momentary value”, “Memory area”: DT
“Register address”: 100
“Data format”: “INT (16 bits, signed)”
“Decimal”: 2

3. Save your configuration.

Configure data logging for KW2M

1. Go to “Log file settings”, select “Add new”, and open the new configuration.
Make the following settings (keep the default settings for all other parameters):
“File name”: KW2M_ETHERNET_70
“COM interface/station number”: ETHERNET, 70 (station number 70 corresponds to the
last octet of the target IP address)
“Trigger cycle time”: 300 (a new value is logged every 5min)

2. Go to “Data point settings”, select “Add new”, and select the new data point from the list.
Make the following settings:
“Data point name”: Energy
“Unit”: kWh
“COM interface”: ETHERNET, “Station number”: 70
“Register type”: “Momentary value”, “Memory area”: DT
“Register address”: 112
“Data format”: “UINT64 (64 bits, unsigned)”
“Decimal”: 3

3. Go to “Log file settings”, select “Add new”, and open the new configuration.
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Make the following settings (keep the default settings for all other parameters):
“File name”: KW2M_ETHERNET_71
“COM interface/station number”: ETHERNET, 71 (station number 71 corresponds to the
last octet of the target IP address)
“Trigger cycle time”: 300 (a new value is logged every 5min)

4. Go to “Data point settings”, select “Add new”, and select the new data point from the list.
Make the following settings:
“Data point name”: Energy
“Unit”: kWh
“COM interface”: ETHERNET, “Station number”: 71
“Register type”: “Momentary value”, “Memory area”: DT
“Register address”: 112
“Data format”: “UINT64 (64 bits, unsigned)”
“Decimal”: 3

5. Save your configuration.

Configure data logging for KW9M

1. Go to “Log file settings”, select “Add new”, and open the new configuration.
Make the following settings (keep the default settings for all other parameters):
“File name”: KW9M_RS485_1
“COM interface/station number”: RS485/232, 1
“Trigger cycle time”: 300 (a new value is logged every 5min)

2. Go to “Data point settings”, select “Add new”, and select the new data point from the list.
Make the following settings:
“Data point name”: Energy
“Unit”: kWh
“COM interface”: RS485/232, “Station number”: 1
“Register type”: “Momentary value”, “Memory area”: DT
“Register address”: 106
“Data format”: “UDINT (32 bits, unsigned)”
“Decimal”: 2

3. Go to “Log file settings”, select “Add new”, and open the new configuration.
Make the following settings (keep the default settings for all other parameters):
“File name”: KW9M_RS485_2
“COM interface/station number”: RS485/232, 2
“Trigger cycle time”: 300 (a new value is logged every 5min)

4. Go to “Data point settings”, select “Add new”, and select the new data point from the list.
Make the following settings:
“Data point name”: Energy
“Unit”: kWh
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“COM interface”: RS485/232, “Station number”: 2
“Register type”: “Momentary value”, “Memory area”: DT
“Register address”: 106
“Data format”: “UDINT (32 bits, unsigned)”
“Decimal”: 2

5. Save your configuration.

Related topics

Import variables from CSV files (page 44)

5.6 Import variables from CSV files

Instead of adding single data points, you can import CSV files.

The following restrictions apply:

• A maximum of 700 variables can be imported. Entries beyond this number will be
ignored.

• Data point names that are longer than 30 characters will be cut during import.

• The data types DT, LD, FL, R, Y, and X can be imported. Other data types (e.g. WR, WL,
WX, WY) are skipped and an error message is displayed when the import is finished.

Use the default import settings to import variables that have been exported in Control FPWIN
Pro7 with the default settings.

1. Make general log settings and configure the log file.

2. Go to “Import variables from CSV”.
If you want to change the default settings, select “Show import settings”.
• Select a separator from the “Separator” list box.

• Select “Header rows” if your CSV file contains header rows.
Specify the number of header rows in the CSV file. By default, CSV files have one
header row in Control FPWIN Pro7.
If the header settings do not match your file's header, header rows will not be
imported correctly.

3. Specify the number of the column containing the data point name, the FP address, the
data type, and a comment.
• “Data point name”

Specify the number of the column containing the data point name. The default
column number in Control FPWIN Pro7 is 2 (starting with column 1).

• “FP address”
Specify the number of the column containing the FP address (e.g. DT100, R10). The
default column number in Control FPWIN Pro7 is 4 (starting with column 1).

• “Data type”
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Specify the number of the column containing the data type (e.g. INT, BOOL). The
default column number in Control FPWIN Pro7 is 5 (starting with column 1).

• “Comment”
Specify the number of the column containing the comment. The default column
number in Control FPWIN Pro7 is 7 (starting with column 1). The comment may
contain data point settings (type, decimal, endian, unit, enable_scal, scale_plc_min,
scale_plc_max, scale_log_min, scale_log_max) in a JSON format. Export a file for
an example.

4. Drag a file onto the drag and drop area or select a CSV file with the “+” icon.
A new table view appears when the CSV file has been successfully read.

5. To filter entries in the CSV file, enter any text string in the “Filter” text box (visible after a
CSV file has been loaded).
The text is searched in all columns of the selected CSV file.

6. Select a log file with “Import to configuration”.
The variables from the CSV file are imported into this log configuration.

7. Select the desired entries and click “Import selection”, or click “Import all” to import all
entries from the CSV file.

Related topics

Configure data logging (page 41)

5.7 List and download log files

Use this function to generate a list of all log files and to download individual log files.

1. Go to “Data Logger” > “List and download log files”.

2. Select the file storage area of the log files, and click “List files” to list all files available.

3. To download a single file, click on the file name. To download all files, select “Download
all files”.
This button is disabled if no log file is available.
With “Download all files”, all log files will be saved in a zipped file.

4. To delete one or more entries from the list, select the desired check boxes and click
“Delete selection”. To delete all entries, select “Delete all”.
These buttons are disabled if no files are listed.
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6 Example: HTTP connection to a cloud server

6.1 Functional overview

When you use the FP‑I4C unit as an HTTP client, you can use the HTTP GET and HTTP
POST methods to exchange data with a cloud server. A PLC is needed to control the send
and receive operations.

In this sample application, weather data is collected from the online service OpenWeather
and forwarded to a dashboard provided by Emoncms.org (both offer free access). The
FP‑I4C unit receives the commands via USB/MEWTOCOL from the PLC. The FP‑I4C library
for Control FPWIN Pro7 offers ready-made function blocks that support the HTTP client
service.

OpenWeather content and data are licensed under https://creativecommons.org/licenses/by-
sa/4.0/ .

Emoncms.org content and data are licensed under https://www.gnu.org/licenses/
agpl-3.0.html .

FP0H FP-I4C

Configuration

• The FP‑I4C unit and a PC are connected to the Internet. They obtain their IP addresses
from a DHCP server.

• An FP0H PLC is connected to the FP‑I4C unit via USB.
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Step-by-step instructions

1 Connect the devices (page 47)
Connect an FP0H PLC to the USB port of the FP‑I4C unit, and connect a PC and the
FP‑I4C unit to the Internet.

2 Make FP‑I4C settings (page 48)
Make the communication settings for the FP‑I4C unit, configure the HTTP client, and
download the sample files for Control FPWIN Pro7.

3 Set up the programming examples (page 50)
The programming examples use ready-made function blocks for the HTTP client
service to collect data from a weather server and forward it to a dashboard server.

4 Get weather data from a cloud server (page 51)
Use the sample program to collect data from a weather server.

5 Forward weather data to a dashboard (page 52)
Use the sample program to collect data from a weather server and transmit the data
to a dashboard server.

6 Minimize security risks (page 53)
To minimize security risks, you should take a few precautionary measures.

6.2 Connect the devices

Connect an FP0H PLC to the USB port of the FP‑I4C unit, and connect a PC and the FP‑I4C
unit to the Internet.

• Connect the USB port of the FP0H PLC to the USB port of the FP‑I4C unit.

• Connect the FP‑I4C unit and your PC to the network, and set the IP address of the
FP‑I4C unit.
Because we use a DHCP server, connect the LAN cable to the ETH0 connector of the
FP‑I4C unit.
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Related topics

Connect the FP‑I4C unit to a PC via DHCP server (page 30)

6.3 Make FP‑I4C settings

Make the communication settings for the FP‑I4C unit, configure the HTTP client, and
download the sample files for Control FPWIN Pro7.

This task includes the following steps:

1 Make the FP‑I4C communication settings
Use the PLC connection wizard to enable the COM3 USB interface for
communication with the FP0H PLC and to configure a redirect from the TCP port to
the USB interface.

2 Configure the HTTP client
To set up the FP‑I4C unit to function as an HTTP client, you need to enable the
function and specify a memory area in the PLC for the DUT that handles the data
exchange.

3 Download the sample files

Make the FP‑I4C communication settings

1. Start HMWIN Studio to find out the IP address of the FP‑I4C unit.

2. Go to “Run” > “Manage Target” and select the “Board” tab.
In the device list of your DHCP network you can find the IP address of theFP‑I4C unit.
If there are multiple devices in the list, compare the MAC address to the MAC address
of the ETH0 connector to find the right device. The MAC address is printed on a label
that can be found on the unit's housing.

3. Open your browser and enter the URL https://[IP address]/
machine_config. Replace [IP address] with the IP address of your FP‑I4C unit
(e.g. https://192.168.100.10/machine_config).
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Depending on your browser, an insecure connection warning may be displayed.
Follow the instructions in your browser to accept the connection. You will then be
forwarded to the Web interface of the FP‑I4C unit.

4. Log in with the default or your modified administrator credentials.

5. Select “Application Settings” to go to the application settings area.

6. Go to “COM Interface” and select “Start wizard”.

7. Select “Simple mode” and “Continue”.

8. Select “COM3 USB” and “Continue”.

9. Enter port number 9096 (or any other port between 1025 and 65535).

10. Select “Finish”.
All packages received on the specified port are now forwarded to the PLC via the
serial interface.

11. Save your configuration.

Configure the HTTP client

1. Go to the “HTTP Client” page and enable the HTTP client function.

2. Specify free DT registers in the user area of the PLC that can be used to control data
transmission.
The same address must be set in the corresponding DUT of the programming example.
The server IP address and the login parameters are set in the PLC. Do not enter any
data in these fields in this example.
Do not enable “Use HTTPS” for now. If you want to establish a secure connection later,
specify at least a list of CA root certificates. For more information, please refer to your
HTTP server provider.

3. Save your configuration.

Download the sample files

Download the FP‑I4C library for Control FPWIN Pro7 and the HTTP client example by
clicking on the two “Save to PC” buttons.

Related topics

Connect the FP‑I4C unit to a PC via DHCP server (page 30)
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6.4 Set up the programming examples

The programming examples use ready-made function blocks for the HTTP client service to
collect data from a weather server and forward it to a dashboard server.

Control
FPWIN Pro7

Download the FP‑I4C library and the programming example for Control FPWIN Pro7 on the
“HTTP Client” page.

1. Unzip the downloaded library and sample files.

2. Double-click the file HTTPC_example.pce to open the sample project in Control
FPWIN Pro7.
The library is automatically installed when the project is opened.
The project contains different sample POUs. These POUs contain all settings required
to establish a connection with a weather server.

3. Go to “Online” > “Communication settings... ”.
Make the following settings:
“Connection type”: “Ethernet”
“Configuration name”: Enter a name for your Ethernet connection.
“Use ET-LAN unit”: Disabled
“PC settings”:
• “IP address”: 0.0.0.0

• “Port number”: 0

“Destination settings”:
• “IP address”: Enter the IP address of the FP‑I4C unit.

• “Port number”: Enter the port number of the FP‑I4C unit (in this example 9096).

“Communication timeout (s)”: 15s
“Connection timeout (s)”: 60s
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6.5 Get weather data from a cloud server

Use the sample program to collect data from a weather server.

Control
FPWIN Pro7

FP0H FP-I4C

In this example, we will use the POU "Easy_HTTP_Client". This POU contains all settings
required to establish a connection with a weather server.

Prepare and compile the PLC program:

• Make sure that the POU "Easy_HTTP_Client" is the only POU assigned to the program
task.

• Replace the value for the parameter appid in the variable sMyCommandToSend with
your API key.

You must register on the home page of the provider (api.openweathermap.org ) to get
your own API key.

• Specify the start address of the g_dutFPI4C_HTTPClient DUT in the global variable list.
The default setting is DT240. (If you kept the default value DT240 on the "HTTP client"
page, you do not need to change the address.)

The project is now ready to be compiled and transmitted to the PLC.

• Select “Online” > “Online mode”, then “Compile all...” and “Download program code and
PLC configuration to PLC” to transmit the program to the PLC.

Start communication with the weather server and monitor your POU:

• Double-click on the variable bTrigger to turn the value of the Boolean variable to TRUE.
Communication with the weather server starts and weather data is received.

• Select “Monitor” > “Entry data monitor” to monitor your POU.
If the communication is working properly, you can read the weather data in the string
variable g_sHTTPC_Receive.
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6.6 Forward weather data to a dashboard

Use the sample program to collect data from a weather server and transmit the data to a
dashboard server.

Control
FPWIN Pro7

FP0H FP-I4C

In this example, we will use the POU "Weather_Power_Values_EMONCMS_GET_Method".
This POU contains all settings required to establish a connection with a weather
server. (Depending on the HTTP server you choose, you can also use the POU
"Weather_Power_Values_EMONCMS_POST_Method". Emoncms.org supports both
methods.)

Prepare and compile the PLC program:

• Make sure that the POU "Weather_Power_Values_EMONCMS_GET_Method" is the only
POU assigned to the program task.

• Replace the value for the parameter appid in the variable sFileOr_URL with your API
key of the weather data server (registration on api.openweathermap.org  required).

• Replace the value of the variable sEmoncmsAPIKey of this POU with your API key of
the dashboard server (registration on emoncms.org  required).

The project is now ready to be compiled and transmitted to the PLC.

• Select “Online” > “Online mode”, then “Compile all...” and “Download program code and
PLC configuration to PLC” to transmit the program to the PLC.
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Start communication with the weather server and the dashboard server:

• Double-click on the variable bTrigger to turn the value of the Boolean variable to TRUE.
First, communication with the weather server starts and weather data is received. Then
the HTTP client transmits weather information to the dashboard server.

If the communication is working properly, the weather data is displayed in your Emoncms
profile and workspace. Please refer to the tutorials on the Emoncms Web site for details
on how to configure your workspace.

6.7 Minimize security risks

To minimize security risks, you should take a few precautionary measures.

• Change the default passwords of the FP-I4C unit to new and more complex passwords.

• Be sure that only those FP-I4C services are enabled that are actually used by your
application.

• Use encrypted transmission methods for your communication. A root CA certificate list or
self-signed certificates help to ensure that you are communicating with the correct server.
Please be aware that public root CA certificate lists expire after a certain time.

FP-I4C Unit  53



7 Example: Web-based data visualization

7 Example: Web-based data visualization

7.1 Functional overview

The FP‑I4C unit can be used as a Web server to visualize data from different sources.

In this sample application, two Panasonic PLCs are connected to the FP‑I4C unit. You will
learn how to create a simple Web page that displays data from these PLCs in a browser.

An FP0R PLC is connected via RS232C and MEWTOCOL, and an FP0H PLC is connected
via Ethernet and Modbus TCP.

To create the Web pages and store them in the FP‑I4C unit, use HMWIN Studio version 4.0
or newer. The software is available free of charge in our Panasonic Download Center .

A

FP-I4CFP0H FP0R

B

FP0H FP-I4C FP0R

A: Direct connection of the devices, B: Connection using a network switch

Configuration

• The FP‑I4C unit has the fixed IP address 192.168.0.1.

• The FP0H PLC has the IP address 192.168.0.21. Two server connections have been
enabled for Modbus TCP, one for data communication via port 502 and another one to
control the PLC via port 9094.

• The FP0R PLC is connected to the FP‑I4C unit with its TOOL port (115200 baud, odd
parity, MEWTOCOL-COM protocol).

• The PC has the static IP address 192.168.0.10.

Step-by-step instructions

1 Configure the FP0H PLC (page 55)
Make the communication settings for the PLC in Control FPWIN Pro7.

2 Connect the FP0R PLC to the FP‑I4C unit (page 56)
Connect the FP0R and FP‑I4C units and make the TOOL port settings for the PLC.
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3 Connect the PC and the FP0H PLC to the FP‑I4C unit (page 57)
Use a LAN cable to connect your PC, the FP0H PLC, and the FP‑I4C unit, either
directly or via a network switch.

4 Make FP‑I4C settings (page 57)
Make the communication settings for the COM1 RS232 interface and configure a
redirection from the TCP port to the COM1 RS232 interface.

5 Create a Web page (page 59)
Use HMWIN Studio to configure the PLC connections and to create a Web page that
shows the status of four PLC variables.

6 Import variables in HMWIN Studio (page 62)
If you do not want to enter the variables manually, you can import them from a
Control FPWIN Pro7 export file.

7.2 Configure the FP0H PLC

Make the communication settings for the PLC in Control FPWIN Pro7.

FP0H
192.168.0.21

USB Control
FPWIN Pro7

(Replace the IP addresses in this example with the addresses that match your network
configuration.)

1. Connect your PC to the PLC, e.g. with a USB cable, and turn on the power of the PLC.

2. Start the Control FPWIN Pro7 programming software to set the IP address in the FP0H
PLC and configure the Ethernet connection.

3. Open or create a Control FPWIN Pro7 project and make sure the set PLC type is an
FP0H PLC.

4. Go to “PLC” > “System registers” > “Ethernet” > “IP addresses”.
Make the following settings:
“Automatically obtain IPv4 address”: “No” (we need a static IP address)
“IPv4 address”: “192.168.0.21” (must be on the same subnet as the FP‑I4C unit)
“IPv4 subnet mask”: “255.255.255.0”

5. Go to “PLC” > “System registers” > “Ethernet” > “User connections”.
Make the following settings:
“User connection 1”: “Enabled”
“Communication mode”: “Modbus TCP master/slave”
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“Communication method”: “TCP/IP”
“Open method”: “Server connection (unspecified partner)”
“Source port number”: “502”
TCP port 502 will be used for data communication.

6. Go to “PLC” > “System registers” > “Ethernet” > “System connections”.
Make the following settings:
“System connection 1”: “Enabled” (there is just one system connection for the FP0H
PLC)
“Communication mode”: “MEWTOCOL-COM slave”
“Communication method”: “TCP/IP”
“Open method”: “Server connection (unspecified partner)”
“Source port number”: “9094”
TCP port 9094 will be used to control the PLC from a remote PC.

7.3 Connect the FP0R PLC to the FP‑I4C unit

Connect the FP0R and FP‑I4C units and make the TOOL port settings for the PLC.

FP-I4C FP0R

USB Control
FPWIN Pro7

RS232

1. Connect the TOOL port of the FP0R PLC to the COM1 RS232 interface of the FP‑I4C
unit, e.g. using cable AIGT8192 (see "Related topics").

2. Connect your PC to the PLC, e.g. with a USB cable, and turn on the power of the PLC.

3. Start the Control FPWIN Pro7 programming software to configure the TOOL port of the
PLC.

4. Open or create a Control FPWIN Pro7 project and make sure the set PLC type is an
FP0R PLC.

5. Go to “System registers” > “Serial ports” > “TOOL”.
Make the following settings:
“Communication mode”: “MEWTOCOL-COM slave”, “Station number”: “1”, “Baud rate”:
“115200”, “Data length”: “8 bits”, “Parity”: “Odd”, “Stop bits”: “1 bit”

6. When you have completed your settings, transfer the configuration to the PLC.

Related topics

Connection to PLC TOOL port using cable AIGT8192 (page 23)
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7.4 Connect the PC and the FP0H PLC to the FP‑I4C unit

Use a LAN cable to connect your PC, the FP0H PLC, and the FP‑I4C unit, either directly or
via a network switch.

A

FP-I4CFP0H

B

FP0H FP-I4C

FP0R

FP0R192.168.0.21

192.168.0.10

192.168.0.1

192.168.0.10

192.168.0.21 192.168.0.1

Direct connection of the devices (A)

1. Connect the PC with either one of the two Ethernet ports of the FP0H PLC.

2. Connect the other Ethernet port of the FP0H PLC with ETH1 of the FP‑I4C unit.

3. Set the IP address of the PC to 192.168.0.10 (see "Related topics"). The PC must be on
the same subnet as the FP‑I4C unit.

Connection using a network switch (B)

1. Connect the PC with the network switch.

2. Connect one of the two Ethernet ports of the FP0H PLC with the network switch.

3. Connect ETH1 of the FP‑I4C unit with the network switch.

4. Set the IP address of the PC to 192.168.0.10 (see "Related topics"). The PC must be on
the same subnet as the FP‑I4C unit.

Related topics

Connect the FP‑I4C unit directly to a PC (page 29)

7.5 Make FP‑I4C settings

Make the communication settings for the COM1 RS232 interface and configure a redirection
from the TCP port to the COM1 RS232 interface.

Connect your PC to the FP0H PLC or to the network switch to configure the FP‑I4C unit.
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A: Direct connection of the devices, B: Connection using a network switch

1. Open your browser and enter the URL https://192.168.0.1/fp_config.
Depending on your browser, an insecure connection warning may be displayed.
Follow the instructions in your browser to accept the connection. You will then be
forwarded to the Web interface of the FP‑I4C unit.

2. Log in with the default or your modified administrator credentials.

3. Select “Application Settings” to go to the application settings area.

4. Go to “COM Interface” and select “Start wizard”.

5. Select “Simple mode” and “Continue”.

6. Select “COM1 RS232” and “Continue”.

7. Select a baud rate of 115200 and “Odd” parity.

8. Enter port number 9094.

9. Select “Finish”.
All packages received on the specified port are now forwarded to the PLC via the
serial interface.

10. Save your configuration.
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7.6 Create a Web page

Use HMWIN Studio to configure the PLC connections and to create a Web page that shows
the status of four PLC variables.

A

FP-I4CFP0H FP0R

B

FP-I4CFP0H FP0R

A: Direct connection of the devices, B: Connection using a network switch

HMWIN Studio uses tags to display PLC variables. Tags contain information about the
memory location and data type of the variables.

In this example, we define two tags for each PLC:

• For the FP0R PLC, we define a Boolean tag for a 1s clock pulse and an integer tag for
the current value of a ring counter that is increased by one every 2.5ms.

• For the FP0H, we define a Boolean tag for the digital output Y0 and an integer tag for the
current value of the memory area DT0.

The Web page will contain two lamps to visualize the Boolean values and two numeric fields
to display the integer values.

Special flags and special data registers cannot be accessed directly by Modbus TCP but
must be moved to an accessible memory area first. Refer to the Control FPWIN Pro7 online
help for system variables and the corresponding address offsets.

This task includes the following steps:

1 Configure the PLC connections

2 Create tags for PLC variables

3 Create a simple Web page

Configure the PLC connections

1. Start HMWIN Studio and select “File” > “New project” to start the project wizard.

2. Enter a project name and click “Next”.

3. Select the FP‑I4C device and click “Next”.
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4. Select “Unified” and click “Finish” to complete the creation of the new project.

5. Go to “ProjectView” > “Configuration” and double-click “Protocols”.

6. Make settings for the protocol used by the FP0R PLC:
a. Click the “+” icon and select “Panasonic FP/FP7”.

Make the following settings:
“PLC network”: Deactivated
“Alias”: “FP0R”
“Node ID”: “1”
“Media”: “Ethernet”
“Request delay (ms)”: “0”
“IP address”: “127.0.0.1” (localhost)
“Port”: “9094” (must match the specified port redirection in the FP‑I4C unit)
“Timeout (ms)”: “500”
“PLC models”: “FP”

b. Select “OK”.

7. Make settings for the protocol used by the FP0H PLC:
a. Click the “+” icon and select “Modbus TCP”.

Make the following settings:
“PLC Network”: Deactivated
“Alias”: “FP0H”
“IP address”: “192.168.0.21” (must match the IP address setting in Control FPWIN
Pro7)
“Port”: “502”
“Use UDP/IP”: Deactivated
“Encapsulated RTU”: Deactivated
“Timeout (ms)”: “2000”
“Server busy timeout”: “0”
“Busy retry time (ms)”: “20”
“Modbus ID”: “1”
“Max. read bit block”: “2000”
“Write holding registers”: “16”
“Write coils”: “15”
“PLC models”: “Generic Modbus (0 based)”

b. Select “OK”.

Create tags for PLC variables

1. Go to “ProjectView” and double-click “Tags”.

2. Create tags for the protocol used by the FP0R PLC:
a. Select the FP0R protocol and click the “+” icon to add a new tag.

Make the following settings:
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“Memory type”: “R - Internal rel”
“Offset”: “901”
“Data type”: “Boolean”
“SubIndex”: “0x0C”

b. Select “OK” and rename the tag to Pulse1s.

c. Click the “+” icon to add another tag.
Make the following settings:
“Memory type”: “DT - Data reg”
“Offset”: “90019”
“Data type”: “short” (corresponds to INT in the PLC)

d. Select “OK” and rename the tag to RingCounter_2ms5.

3. Create tags for the protocol used by the FP0H PLC:
a. Select the FP0H protocol and click the “+” icon to add a new tag.

Make the following settings:
“Memory type”: “Coil status”
“Offset”: “1” (corresponds to Y0 of the PLC)
“Data type”: “Boolean”

b. Select “OK” and rename the tag to DigitalOutput_Y0.

c. Click the “+” icon to add another tag.
Make the following settings:
“Memory type”: “Holding registers” (corresponds to DT in the PLC)
“Offset”: “400000” (corresponds to DT0 in the PLC, 400001 is DT1 etc.)
“Data type”: “short” (corresponds to INT in the PLC)

d. Select “OK” and rename the tag to DataRegister_DT0.

Create a simple Web page

1. Go to “ProjectView” > “Unified” > “Normal” and double-click “1 : Page1”.

2. Go to “View” > “Toolbars and Docking Windows” > “Widget Gallery” to open a collection
of HMI objects.
The widget gallery is divided into several categories. Simply drag a widget on the page
of your project.

3. Add two numeric fields:
a. Go to the “Basic” > “Text/Numeric” category in the widget gallery.

b. Drag the “99999” widget on the page.

c. Go to the “Properties” panel and select the “+” icon in the “Value” field to add a tag
to the widget.

d. Select the RingCounter_2ms5 tag and click “OK”.

e. To add a label to your widget, drag the “[Label]” widget next to the “99999” widget
and enter "FP0R RingCounter_2ms5" in the “Text” field of the “Properties” panel.

FP-I4C Unit  61



7 Example: Web-based data visualization

f. Repeat the procedure for the DataRegister_DT0 tag and add the label "FP0H
DataRegister_DT0".

4. Add two lamps:
a. Go to the “Symkeys” > “HM Symkeys real elements” category in the widget gallery.

b. Drag a lamp widget on the page.

c. Go to the “Properties” panel and select the “+” icon in the “Value” field.

d. Select the Pulse1s tag and click “OK”.

e. Add the label "FP0R Pulse1s".

f. Repeat the procedure for the DigitalOutput_Y0 tag and add the label "FP0H
DigitalOutput_Y0".

5. Select “Run” > “Download to Target” to transfer the page to the FP‑I4C unit.
HMWIN Studio searches for all units on the same subnet. Select your device and click
“Download”.
The first time you perform a download, HMWIN Studio will ask you to install the HMI
Runtime on your FP‑I4C unit. The installation takes approximately 2 minutes. Then the
unit will automatically reboot.

6. Display the Web page by entering the IP address of your FP‑I4C unit (192.168.0.1) in
your browser.

7.7 Import variables in HMWIN Studio

If you do not want to enter the variables manually, you can import them from a Control
FPWIN Pro7 export file.

1. To export the variables from Control FPWIN Pro7, go to “Project” > “Export” > “Variables
as CSV file” > “Global variables”.

2. To import the variables in HMWIN Studio, go to “Configuration” and double-click on
“Tags”.

3. Select the desired protocol and click the Import Dictionary icon to start the import.

4. Select the Control FPWIN Pro7 import type and the CSV file to be imported.
The available variables are listed in gray color.

5. Select the variables you want to import and click the Import Tags icon.

All imported tags are now listed in black color.
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8 Example: Remote control with Corvina Cloud

8.1 Functional overview

Corvina Cloud is a software platform that allows to remotely manage different devices via a
secured VPN connection from anywhere in the world.

In this sample application, the FP‑I4C unit serves as gateway to communicate with two PLCs
from a remote PC. An FP0R PLC is connected using its RS232C interface, and an FP0H
PLC is connected to the same network via Ethernet.

To purchase a license for Corvina Cloud and obtain administrator credentials, please contact
one of our sales offices.

Control
FPWIN Pro7

FP0HFP-I4C FP0R

VPN VPN

Configuration

• The FP‑I4C unit has the static IP address 192.168.100.10.

• The FP0H PLC has the IP address 192.168.100.11. A server connection has been
enabled to allow remote control of the PLC.

• The FP0R PLC is connected to the FP‑I4C unit with its TOOL port (115200 baud, odd
parity, MEWTOCOL-COM protocol).

• The PC is on the control side (e.g. office, home). The Corvina Cloud Connect app is
installed on the computer.

• The PC is running in a network without proxy server or blocking of outbound ports.

Step-by-step instructions

1 Connect the FP0H PLC to the network (page 64)
Connect the LAN cable and make the Ethernet settings for the PLC.

2 Connect the FP0R PLC to the FP‑I4C unit (page 65)
Connect the FP0R and FP‑I4C units and make the TOOL port settings for the PLC.
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3 Connect the FP‑I4C unit to the network (page 66)
Make the physical network connection, set a static IP address, enable the router
function, and configure the RS232 COM1 interface to the FP0R PLC.

4 Configure the Corvina Cloud (page 68)
Go to the Corvina Cloud Web Portal to configure the Corvina Cloud.

5 Connect the FP‑I4C unit to the Corvina Cloud (page 70)
Make the server settings required to connect to the Corvina Cloud.

6 Connect the PC to the Corvina Cloud (page 71)
This step requires that you install the Corvina Cloud Connect app on the PC that
makes the remote connection to the PLCs.

7 Connect the PLCs with the cloud (page 72)
Establish an online connection between Control FPWIN Pro7 and the PLCs.

8.2 Connect the FP0H PLC to the network

Connect the LAN cable and make the Ethernet settings for the PLC.

FP0H
192.168.100.11

USB Control
FPWIN Pro7

192.168.100.1

(Replace the IP addresses in this example with the addresses that match your network
configuration.)

1. Use a LAN cable to connect either one of the two Ethernet ports of the FP0H PLC with
the router.
The router has the default gateway IP address 192.168.100.1.

2. Connect your PC to the PLC, e.g. with a USB cable, and turn on the power of the PLC.

3. Start the Control FPWIN Pro7 programming software to set the IP address in the FP0H
PLC and configure the Ethernet connection.

4. Open or create a Control FPWIN Pro7 project and make sure the set PLC type is an
FP0H PLC.

5. Go to “PLC” > “System registers” > “Ethernet” > “IP addresses”.
Make the following settings:
“Automatically obtain IPv4 address”: “No” (we need a static IP address)
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“IPv4 address”: “192.168.100.11”
“IPv4 subnet mask”: “255.255.255.0”
“ IPv4 default gateway”: “192.168.100.1”
“Preferred DNS server IPv4 address”: “192.168.100.1”

6. Go to “PLC” > “System registers” > “Ethernet” > “System connections”.
Make the following settings:
“System connection 1”: “Enabled” (there is just one system connection for the FP0H
PLC)
“Communication mode”: “MEWTOCOL-COM slave”
“Communication method”: “TCP/IP”
“Open method”: “Server connection (unspecified partner)”
“Source port number”: “9094”
TCP port 9094 will be used to control the PLC from a remote PC.

7. When you have completed your settings, transfer the configuration to the PLC.

8.3 Connect the FP0R PLC to the FP‑I4C unit

Connect the FP0R and FP‑I4C units and make the TOOL port settings for the PLC.

FP-I4C FP0R

USB
Control
FPWIN Pro7

RS232

1. Connect the TOOL port of the FP0R PLC to the COM1 RS232 interface of the FP‑I4C
unit, e.g. using cable AIGT8192 (see "Related topics").

2. Connect your PC to the PLC, e.g. with a USB cable, and turn on the power of the PLC.

3. Start the Control FPWIN Pro7 programming software to configure the TOOL port of the
PLC.

4. Open or create a Control FPWIN Pro7 project and make sure the set PLC type is an
FP0R PLC.

5. Go to “System registers” > “Serial ports” > “TOOL”.
Make the following settings:
Communication mode: “MEWTOCOL-COM slave”, “Station number”: “1”, “Baud rate”:
“115200”, “Data length”: “8 bits”, “Parity”: “Odd”, “Stop bits”: “1 bit”
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6. When you have completed your settings, transfer the configuration to the PLC.

Related topics

Connection to PLC TOOL port using cable AIGT8192 (page 23)

8.4 Connect the FP‑I4C unit to the network

Make the physical network connection, set a static IP address, enable the router function,
and configure the RS232 COM1 interface to the FP0R PLC.

This task includes the following steps:

1 Make the physical connection

2 Set a static IP address
In a network with a DHCP server, the IP address may change over time. For our
application, we need a static IP address.

3 Enable the router function
The router function is needed to forward incoming packages to the FP0H PLC.

4 Configure the FP‑I4C unit's RS232 COM1 interface to the FP0R PLC

(Replace the IP addresses in this example with the addresses that match your network
configuration.)

Make the physical connection

1. Connect a LAN cable from the router to the FP‑I4C unit. Use the top ETH0 connector,
which is set to DHCP by default.

2. Connect your PC to the same router to find out the IP address of the FP‑I4C unit and to
configure the unit.
Follow the instructions on how to connect the FP‑I4C unit via DHCP server (see
"Related topics").
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Set a static IP address

1. Open your browser and enter the URL https://[IP address]/machine_config.
Replace [IP address] with the IP address of your FP‑I4C unit (e.g.
https://192.168.100.10/machine_config).

2. Log in with the default or your modified administrator credentials.
The user name is "admin", the default password is also "admin".

3. Select “Network” > “Network Interface”.

4. Select “EDIT” and then “DHCP disabled” for “eth0” so that DHCP is disabled for both
Ethernet connectors.
Make the following settings:
“Address”: “192.168.100.10”
“Netmask”: “255.255.255.0”
“Gateway”: “192.168.100.1”

Enable the router function

1. Select “Services” > “Router / NAT / Port forwarding”.

2. Select “EDIT” and turn on the “Enabled” switch.

3. Select “SAVE” to save your settings.

Configure the RS232 COM1 interface to the FP0R PLC

1. Select “Application Settings” to go to the application settings area.

2. Go to “COM Interface” and select “Start wizard” to start the PLC connection wizard.

3. Select “Simple mode” and “Continue”.

4. Select “COM1 RS232” and “Continue”.

5. Select a baud rate of 115200 and “Odd” parity.

6. Enter port number 9094 (must match the application port setting in the Corvina Cloud).

7. Select “Finish”.
All packages received on the specified port are now forwarded to the PLC via the serial
interface.

8. Save your configuration.
After about 10s you can test your connection.

9. Select “Test RS232”.
You should receive a message that the FP0R PLC has been successfully connected
to the RS232 interface. If the connection fails, refer to the troubleshooting section for
advice.
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Related topics

Connect the FP‑I4C unit to a PC via DHCP server (page 30)

The connection test for RS232, RS485, or USB fails (page 73)

8.5 Configure the Corvina Cloud

Go to the Corvina Cloud Web Portal to configure the Corvina Cloud.

FP0H FP-I4C FP0R

(1)

(2) (3)

(1) Router
(2) Endpoint
(3) Gateway

This task includes the following steps:

1 Create a device to define the FP‑I4C unit as a gateway

2 Create an application to give Control FPWIN Pro7 access to the PLCs

3 Create a profile to group your applications (there is only one in this example)

4 Add the profile to the device

Create a device

1. Go to https://corvinacloud.com/  and log in with your credentials.

2. Go to “DEVICES” and select “Add gateway”.
A gateway can be any device that can connect to the Corvina Cloud, e.g. FP‑I4C, HMe,
HMX.
Make the following settings:
“Name”: Enter a unique name that can be used to identify the FP‑I4C gateway when you
connect your devices to the Corvina Cloud, e.g. “FPI4C_Gateway”.
“Organization”: Select your organization from the list.
“Description”: Enter an optional description, e.g. “Gateway to the Corvina Cloud”.
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“Serial number”: Enter the code you received after purchasing the license.
“Password”: Enter a password (must contain at least 8 characters and one non-
alphanumeric character).
“Confirm password”: Confirm your password by retyping it.
“Enabled”: Activated

3. Select “Add” to save your settings.

Create an application

1. Go to “APPLICATIONS” and select “Add application”.
Make the following settings:
“Name”: Enter a unique name, e.g. “RemoteControlPLC”.
“Organization”: Select your organization from the list.
“Description”: Enter an optional description, e.g. “Remote control of PLCs”.
“Application type”: “Custom”
“Protocol”: “TCP”
“Port”: “9094” (must match the port setting for COM1 RS232 of the FP‑I4C unit).
Keep the default settings under “Environments”.

2. Select “Add” to save your settings.

Create a profile

1. Go to “APPLICATIONS” > “PROFILES” and select “Add profile”.
Make the following settings:
“Name”: Enter a unique name, e.g. “RemoteControl”
“Organization”: Select your organization from the list.
“Description”: “Remote control for endpoints” (optional)

2. Under “Applications”, select “RemoteControlPLC” and click on “>>”.
The application is moved under “Selected”.

3. Select “Add” to save your settings.

Add the profile to the device

1. Go to “DEVICES”.

2. Select the pencil icon for the device “FPI4C_Gateway”.

3. Select the “Endpoints” tab.
Make the following settings:
“Maximum number of endpoints”: “2” (FP0H PLC is the only endpoint in this example)
“Local network”: Empty
“Do not translate real IPs into virtual IPs (1:1 NAT)”: Deactivated

4. In the endpoint list, go to the gateway with IP address 127.0.0.1, double-click under
“Application profile”, and select the profile “RemoteControl”.
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5. Select “Add row”.
Make the following settings:
“Name”: “FP0H”
“IP address”: “192.168.100.11” (must match the setting for “IPv4 address” in the FP0H
PLC)
“Description”: “Endpoint FP0H” (optional)
“Application profile”: Select “RemoteControl”.
“Enabled”: “yes”
“Source NAT”: “no”
“Custom”: Empty

6. Select “Change” to save your settings.

The device “FPI4C_Gateway” is now displayed on the “Dashboard”. The status is still
“offline”.

8.6 Connect the FP‑I4C unit to the Corvina Cloud

Make the server settings required to connect to the Corvina Cloud.

1. Open your browser and enter the URL https://[IP address]/machine_config.
Replace [IP address] with the IP address of your FP‑I4C unit (e.g.
https://192.168.100.10/machine_config).

2. Log in with the default or your modified administrator credentials.
The default user name is "admin", the default password is "admin".

3. Select “Services” > “Cloud Service”.

4. Select “EDIT” and turn on the “Enabled” switch.
Make the following settings:
“Autostart”: Activate this setting to reconnect the unit automatically to the Corvina Cloud
after a reboot.
“Server type”: “Cloud Server”
“Server”: Empty
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“Username”: Enter the device name (“FPI4C_Gateway”) and organization name (as
shown in Corvina Cloud) in the format device_name@organization_name.
“Password”: Enter the password you created for your device.

5. Select “SAVE” to save your settings.

Once the connection to the Corvina Cloud has been established, your device will be
displayed on the “DASHBOARD” of the Corvina Cloud.

If the connection fails, refer to the troubleshooting section for advice.

Related topics

Troubleshooting (page 73)

8.7 Connect the PC to the Corvina Cloud

This step requires that you install the Corvina Cloud Connect app on the PC that makes the
remote connection to the PLCs.

The software is available free of charge in our Panasonic Download Center .

Make sure no proxy server is used in your network and no outbound ports are blocked. (Port
1194 is needed to connect to Corvina Cloud.)

Corvina Cloud App

1. Install Corvina Cloud Connect on your PC.

2. On the start page, select the gear icon to enter your connection profile.
Make the following settings:
“Profile name”: “Remote control” (or any other name)
“Server type”: “Cloud Server”
“Username”: Use the format username@organization_name.
“Organization”: Leave empty.
“Password”: Password

3. Select “OK” to save your settings.
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4. Select your profile and click on “SIGN IN” to log in to the Corvina Cloud.

5. On the Corvina Cloud “DASHBOARD”, the status of the device “FPI4C_Gateway”
should now be "online".

6. Click on the device “FPI4C_Gateway” and select “Connect to all endpoints” in the
gateway window.
Write down the “VPN IP address” of the gateway because you will need to enter it in
Control FPWIN Pro7.

7. Close the gateway window.

8. Click on the arrow next to the device “FPI4C_Gateway” to display the list of endpoints.

9. Select the FP0H PLC.
Write down the “VPN IP address” of the endpoint because you will need to enter it in
Control FPWIN Pro7.

8.8 Connect the PLCs with the cloud

Establish an online connection between Control FPWIN Pro7 and the PLCs.

Control
FPWIN Pro7

FP0H
100.64.0.241

VPN VPN

FP0R
192.18.138.210

Perform this task for each PLC type.

1. Start Control FPWIN Pro7.

2. Open your project.

3. Go to “Online” > “Communication settings... ”.
Make the following settings:
“Connection type”: “Ethernet”
“Configuration name”: Enter a title for your Ethernet connection.
“Use ET-LAN unit”: Disabled
“PC settings”:
• “IP address”: 0.0.0.0 (The appropriate network card is selected automatically.)

• “Port number”: 0 (The next available port is selected automatically.)

“Destination settings”:
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• “IP address”: Enter the virtual IP address displayed in the Corvina Cloud for the
gateway and for the endpoint, e.g. 192.18.138.210 for FP0R and 100.64.0.241 for
FP0H.

• “Port number”: 9094 (must match the port setting for COM1 RS232 of the FP‑I4C
unit)

4. Select “OK” to save your settings.

5. Select “Online” > “Online mode” to establish the VPN connection to both PLCs.
If the connection fails, refer to the troubleshooting section for advice.

6. Transfer the configuration to the PLC.

Related topics

Troubleshooting (page 73)

8.9 Troubleshooting

If the connection to the Corvina Cloud cannot be established, check the list of possible
causes.

The connection test for RS232, RS485, or USB fails

• Make sure the communication settings for the RS232 or RS485 interface in the PLC and
in the FP‑I4C unit are identical in both devices.

• Check the wiring. For RS232, there are three wires (R, S, and G). Make sure G is
connected to G, R to S, and S to R.

• The system was not ready yet. Wait a few seconds, then test the connection again.

• The PLC is not ready (powered off).

• If you are using HMWIN Studio, make sure COM1 is not used by your HMWIN Studio
project.

The connection of the FP‑I4C unit to the Corvina Cloud fails

• Open your browser and enter the URL https://[IP address]/machine_config.
Replace [IP address] with the IP address of your FP‑I4C unit (e.g.
https://192.168.100.10/machine_config). Check your settings under
“Services” > “Cloud Services”. Substitute "xxx.xx" with the last digits of the unit's IP
address (e.g. https://192.168.100.10/machine_config).
Make sure the settings match your device configuration in the Corvina Cloud (user name,
password, organization name, etc.).

• Check the Internet connection of the FP‑I4C unit.

• Check if there are any port restrictions in your network. The FP‑I4C unit uses port 1194 to
connect to the Corvina Cloud. Make sure this port is not blocked.
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• Make sure the time and date in the FP‑I4C unit are correct. Otherwise, the certificate
is not accepted by the Corvina Cloud. Go to the “Time/Date” page in the FP‑I4C Web
interface and set the correct time and date.

• Make sure the DNS is set correctly. Open your browser and enter the URL https://[IP
address]/machine_config. Replace [IP address] with the IP address of your
FP‑I4C unit (e.g. https://192.168.100.10/machine_config). Check your settings
under “Network” > “Network Interface ”.

The cloud connection to a PLC fails

• Open the Corvina Cloud Connection app and make sure all endpoints are connected.
See Connect the PC to the Corvina Cloud (page 71).

• If you have more than one network configuration on your PC, make sure you are
connected to the right network. We recommend that you disable the other networks
(e.g. Wifi). Otherwise, you need to determine the interface for your Corvina Cloud
connection and enter the corresponding IP address in Control FPWIN Pro7 with
“Online” > “Communication parameters... ” > “Computer” > “IP address”.

• Check the LAN cable connection between the router and the Ethernet port of the FP0H
PLC, and make sure the PLC is powered on.

• Make sure a system or user connection with source port 9094 is enabled in the project
downloaded to the FP0H PLC. See Connect the FP0H PLC to the network (page 64).
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9 Record of changes

ACGM0162V4EN, 2022.07

Added application example for Corvina Cloud

Added pre-startup checklist

Updated list of features

Corrected list of applicable EU directives and standards

Added description of basic communication processes and port redirections

Corrected instructions for changing passwords

Updated software user interface descriptions

Added new graphics in section "Getting started" and in application examples

ACGM0162V3EN, 2021.01

Updated list of features

Added unit dimensions with Phoenix Contact connector installed

Added information on changing access credentials and restrictions

Added application example for data logging from different devices

Added application example for the HTTP client function

Added application example for Web-based data visualization

ACGM0162V2EN, 2020.06

Cover page: changed manual title, corrected product name

Frontmatter: added software legal notes, safety precautions, network security notes

Corrected list of features

Deleted section on hardware version information

Updated description of LEDs

Specifications: corrected product number and list of supported protocols, corrected operating
voltage range, corrected operating and storage humidity

Added dimensional drawing

Devices supported by USB host ports: added FP0R

Revised installation instructions for FP0R expansion units

Corrected wiring diagram for "Connecting the TOOL port" with COM1

Revised section "Getting started"
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ACGM0162V1EN, 2019.07

First edition
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